summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-08 13:30:05 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-08 13:30:41 +0200
commit97af34fac31a8106b199b468309c22d797fbbbc1 (patch)
tree691ea802196f7b58398ba77f49b6c6a70b774c6d
parentapp-admin/conky: Remove old. (diff)
downloadgentoo-97af34fac31a8106b199b468309c22d797fbbbc1.tar.gz
gentoo-97af34fac31a8106b199b468309c22d797fbbbc1.tar.bz2
gentoo-97af34fac31a8106b199b468309c22d797fbbbc1.zip
dev-libs/xxhash: Mark ~hppa too.
Package-Manager: Portage-2.3.49, Repoman-2.3.10 RepoMan-Options: --ignore-arches
-rw-r--r--dev-libs/xxhash/xxhash-0.6.5.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-libs/xxhash/xxhash-0.6.5.ebuild b/dev-libs/xxhash/xxhash-0.6.5.ebuild
index 2b31be40a067..f23c18c478a8 100644
--- a/dev-libs/xxhash/xxhash-0.6.5.ebuild
+++ b/dev-libs/xxhash/xxhash-0.6.5.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
HOMEPAGE="http://www.xxhash.com"
@@ -11,13 +10,17 @@ SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="BSD-2 GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x64-macos"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x64-macos"
IUSE="static-libs"
DEPEND=""
S="${WORKDIR}/xxHash-${PV}"
+src_configure() {
+ use hppa && replace-flags '-O*' '-O0'
+}
+
src_compile() {
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \