summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-01 18:55:51 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-01 18:56:14 +0200
commit97b316f2e40bca7bf5e43ecc588ed47e1787b4b6 (patch)
tree01203a20a8f559c2767b1fcb6b694b5e5030141e
parentdev-libs/clearsilver: Add Java support. Fixes bug 251091. (diff)
downloadgentoo-97b316f2e40bca7bf5e43ecc588ed47e1787b4b6.tar.gz
gentoo-97b316f2e40bca7bf5e43ecc588ed47e1787b4b6.tar.bz2
gentoo-97b316f2e40bca7bf5e43ecc588ed47e1787b4b6.zip
dev-python/miniupnpc: Version bump to match net-libs/miniupnpc
Package-Manager: portage-2.2.20
-rw-r--r--dev-python/miniupnpc/Manifest1
-rw-r--r--dev-python/miniupnpc/files/miniupnpc-1.9.20150917-shared-lib.patch24
-rw-r--r--dev-python/miniupnpc/miniupnpc-1.9.20150917.ebuild28
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/miniupnpc/Manifest b/dev-python/miniupnpc/Manifest
index 5cf930000730..047bb67b9a60 100644
--- a/dev-python/miniupnpc/Manifest
+++ b/dev-python/miniupnpc/Manifest
@@ -1 +1,2 @@
DIST miniupnpc-1.8.tar.gz 70624 SHA256 bc5f73c7b0056252c1888a80e6075787a1e1e9112b808f863a245483ff79859c SHA512 8eedac9ad473fc952ca8896fe534d6da6b1b234e8b6f35f721394d4c71aca84ed287ca6c4f0455b50d97a45e4cd34e27d99a6813386e0864781364aa607e13d4 WHIRLPOOL 5b76ccbb5ed7daa9bb0d481b424b7c31a5f6dc85c5c812ba10175a29aefc0d3924f3db2aa8c3529d1241be59d67d1d4c702d27aad2de8c8a07fecf3857d73169
+DIST miniupnpc-1.9.20150917.tar.gz 82609 SHA256 3087c32929c1e9db4947d6a184694e06ec604bca29449b75daec295a5d8f11da SHA512 1fe2613d19cbd16b6f6e9c8205e984548fb96d032a71a849f9b25486dc71b07ee270d2bfc324f218abe80c45f0b13b6af00e59cbf3a9e35b83ea5073bb897f65 WHIRLPOOL 60d0e9c94ddf8ef19106217158d01cc2f3edb854f34326c80c6ae694b65b80f1bc6810cc2b24a7b8525ef7c3982324c9859bdbdcb2e2e944747c371ba2015a6a
diff --git a/dev-python/miniupnpc/files/miniupnpc-1.9.20150917-shared-lib.patch b/dev-python/miniupnpc/files/miniupnpc-1.9.20150917-shared-lib.patch
new file mode 100644
index 000000000000..4765c6e79650
--- /dev/null
+++ b/dev-python/miniupnpc/files/miniupnpc-1.9.20150917-shared-lib.patch
@@ -0,0 +1,24 @@
+From cd8787999bf4c4b89601f6338ce765ea6229232c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 1 Oct 2015 18:49:26 +0200
+Subject: [PATCH] Use shared library when linking Python extensions
+
+---
+ miniupnpc/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/miniupnpc/setup.py b/miniupnpc/setup.py
+index 049f670..2533ed4 100644
+--- a/miniupnpc/setup.py
++++ b/miniupnpc/setup.py
+@@ -19,6 +19,6 @@ setup(name="miniupnpc",
+ description='miniUPnP client',
+ ext_modules=[
+ Extension(name="miniupnpc", sources=["miniupnpcmodule.c"],
+- extra_objects=["libminiupnpc.a"])
++ libraries=["miniupnpc"])
+ ])
+
+--
+2.6.0
+
diff --git a/dev-python/miniupnpc/miniupnpc-1.9.20150917.ebuild b/dev-python/miniupnpc/miniupnpc-1.9.20150917.ebuild
new file mode 100644
index 000000000000..6e36f37601cc
--- /dev/null
+++ b/dev-python/miniupnpc/miniupnpc-1.9.20150917.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for UPnP client library"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/miniupnpc-${PV}:0="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/miniupnpc-1.9.20150917-shared-lib.patch
+)
+
+# DOCS are installed by net-libs/miniupnpc.
+DOCS=()