summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-17 16:04:10 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-17 16:04:10 -0400
commit97e297085c06b587a90e43b0c466b0d94c092ba4 (patch)
treeced8ed15fffc695b4c0829822c39a4afd2ca5768
parentmedia-gfx/sxiv: make gif/exif support optional and add live ebuild (diff)
downloadgentoo-97e297085c06b587a90e43b0c466b0d94c092ba4.tar.gz
gentoo-97e297085c06b587a90e43b0c466b0d94c092ba4.tar.bz2
gentoo-97e297085c06b587a90e43b0c466b0d94c092ba4.zip
media-gfx/sxiv: use build options to disable exif/gif support
-rw-r--r--media-gfx/sxiv/sxiv-9999.ebuild20
1 files changed, 4 insertions, 16 deletions
diff --git a/media-gfx/sxiv/sxiv-9999.ebuild b/media-gfx/sxiv/sxiv-9999.ebuild
index 75f593a1b0f9..d6b5f0192b8f 100644
--- a/media-gfx/sxiv/sxiv-9999.ebuild
+++ b/media-gfx/sxiv/sxiv-9999.ebuild
@@ -31,28 +31,16 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -i '/^LDFLAGS/d' Makefile || die
- # disable exif support as required
- if ! use exif; then
- sed \
- -e 's/^.* -DHAVE_GIFLIB/#\0/' \
- -e 's/^.* -lgif/#\0/' \
- -i Makefile || die
- fi
-
- # disable gif support as required
- if ! use gif; then
- sed \
- -e 's/^.* -DHAVE_LIBEXIF/#\0/' \
- -e 's/^.* -lexif/#\0/' \
- -i Makefile || die
- fi
-
tc-export CC
restore_config config.h
default
}
+src_compile() {
+ emake $(usex exif "" NO_LIBEXIF=1) $(usex gif "" NO_GIFLIB=1)
+}
+
src_install() {
emake DESTDIR="${ED}" PREFIX=/usr install
emake -C icon DESTDIR="${ED}" PREFIX=/usr install