summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-04-18 12:49:49 +0500
committerMichał Górny <mgorny@gentoo.org>2017-04-20 18:14:30 +0200
commit984ddfca7e5d602988b77377e6539abc20bb8d27 (patch)
tree7b4cfcbda3736ab8bc1b2c6a670a0083cb3e9ca0
parentgnome-base/gdm: Update Gentoo logo license, #293309 (diff)
downloadgentoo-984ddfca7e5d602988b77377e6539abc20bb8d27.tar.gz
gentoo-984ddfca7e5d602988b77377e6539abc20bb8d27.tar.bz2
gentoo-984ddfca7e5d602988b77377e6539abc20bb8d27.zip
app-text/cmark: use python-any-r1 instead hardcoded, #615908
Bug: https://bugs.gentoo.org/615908 Closes: https://github.com/gentoo/gentoo/pull/4437 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-text/cmark/cmark-0.27.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-text/cmark/cmark-0.27.1.ebuild b/app-text/cmark/cmark-0.27.1.ebuild
index b7ae5b0f010e..a69f2b36f50b 100644
--- a/app-text/cmark/cmark-0.27.1.ebuild
+++ b/app-text/cmark/cmark-0.27.1.ebuild
@@ -3,7 +3,9 @@
EAPI=6
-inherit cmake-utils
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit cmake-utils python-any-r1
DESCRIPTION="CommonMark parsing and rendering library and program in C"
HOMEPAGE="https://github.com/jgm/cmark"
@@ -15,9 +17,13 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
- test? ( || ( dev-lang/python:3.4 dev-lang/python:3.5 ) )"
+ test? ( ${PYTHON_DEPS} )"
RDEPEND=""
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_prepare() {
cmake-utils_src_prepare
# Remove static library from installing