summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-11-06 18:47:18 -0800
committerZac Medico <zmedico@gentoo.org>2017-11-06 19:00:12 -0800
commit9877ece5ec33f085299200a2802fa223658e50bd (patch)
tree9be94cc83459503a16dbeb4684792c309b0f60e3
parentapp-emulation/wine-vanilla: remove accidental patchbin dep (diff)
downloadgentoo-9877ece5ec33f085299200a2802fa223658e50bd.tar.gz
gentoo-9877ece5ec33f085299200a2802fa223658e50bd.tar.bz2
gentoo-9877ece5ec33f085299200a2802fa223658e50bd.zip
dev-python/pyghmi: new package
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/metadata.xml11
-rw-r--r--dev-python/pyghmi/pyghmi-1.0.22.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
new file mode 100644
index 000000000000..f5ea33f711b9
--- /dev/null
+++ b/dev-python/pyghmi/Manifest
@@ -0,0 +1 @@
+DIST pyghmi-1.0.22.tar.gz 123267 SHA256 8024931866a0ff68404dc0d38db2b516920f1b0fe68ac67da33647a06f336c7a SHA512 9e3bc6b5f33d5496d7e58d2ea558d20d45a7690d493f2d1ad56fdd5570279a38e8934d8425c3d3207d8001da85a9a0b1319463b802fa9f121db7448aa919bddc WHIRLPOOL 9884a43fa69da4bba156fdf4140c7aebdfcfdaa02cd193da979734544971fd16dca0846f5b896e2f7f65111b6aff1991628a6ca25fc94e3a6b08855add76c407
diff --git a/dev-python/pyghmi/metadata.xml b/dev-python/pyghmi/metadata.xml
new file mode 100644
index 000000000000..9ae992913b2b
--- /dev/null
+++ b/dev-python/pyghmi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pyghmi</remote-id>
+ <remote-id type="github">openstack/pyghmi</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyghmi/pyghmi-1.0.22.ebuild b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
new file mode 100644
index 000000000000..7af3e3962a62
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.0.22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py testr --coverage || die "Tests failed under ${EPYTHON}"
+}