summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 13:08:17 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 13:09:19 +0200
commit99bb849b6959766671fe7f33fa2848afefd90eba (patch)
tree168c51ad35853e9293f28dfc4e0742c022b9fc93
parentdev-python/unittest2: Drop deprecated usage of DISTUTILS_NO_PARALLEL_BUILD (diff)
downloadgentoo-99bb849b6959766671fe7f33fa2848afefd90eba.tar.gz
gentoo-99bb849b6959766671fe7f33fa2848afefd90eba.tar.bz2
gentoo-99bb849b6959766671fe7f33fa2848afefd90eba.zip
www-servers/tornado: Drop deprecated usage of DISTUTILS_NO_PARALLEL_BUILD
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--www-servers/tornado/tornado-3.1.1-r1.ebuild9
-rw-r--r--www-servers/tornado/tornado-3.1.1.ebuild9
2 files changed, 0 insertions, 18 deletions
diff --git a/www-servers/tornado/tornado-3.1.1-r1.ebuild b/www-servers/tornado/tornado-3.1.1-r1.ebuild
index b48f92c695a7..809c7489a13a 100644
--- a/www-servers/tornado/tornado-3.1.1-r1.ebuild
+++ b/www-servers/tornado/tornado-3.1.1-r1.ebuild
@@ -33,15 +33,6 @@ PATCHES=(
"${FILESDIR}/${P}-py2_6-tests-fix.patch"
)
-src_test() {
- # The test server tries to bind at an unused port but suffers
- # a race condition in it. Seems to be fixed already.
- # https://github.com/facebook/tornado/blob/master/tornado/test/process_test.py#L64
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
python_test() {
cd "${TMPDIR}" || die
"${PYTHON}" -m tornado.test.runtests || die "Tests fail with ${EPYTHON}"
diff --git a/www-servers/tornado/tornado-3.1.1.ebuild b/www-servers/tornado/tornado-3.1.1.ebuild
index c75f41678037..9656bcb1eca2 100644
--- a/www-servers/tornado/tornado-3.1.1.ebuild
+++ b/www-servers/tornado/tornado-3.1.1.ebuild
@@ -23,15 +23,6 @@ DEPEND="${RDEPEND}
REQUIRED_USE="curl? ( || ( $(python_gen_useflags python2*) ) )"
-src_test() {
- # The test server tries to bind at an unused port but suffers
- # a race condition in it. Seems to be fixed already.
- # https://github.com/facebook/tornado/blob/master/tornado/test/process_test.py#L64
- local DISTUTILS_NO_PARALLEL_BUILD=1
-
- distutils-r1_src_test
-}
-
python_test() {
cd "${TMPDIR}" || die
"${PYTHON}" -m tornado.test.runtests || die "Tests fail with ${EPYTHON}"