summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-30 21:09:59 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-30 21:26:38 +0100
commit9a4d4f488554671883b8244b6a11a89de2c99f6d (patch)
treeb2b7f9800393357ad4297d9100b7c5eb9b76ecae
parentdev-python/django-pglocks: add python3_9 support (diff)
downloadgentoo-9a4d4f488554671883b8244b6a11a89de2c99f6d.tar.gz
gentoo-9a4d4f488554671883b8244b6a11a89de2c99f6d.tar.bz2
gentoo-9a4d4f488554671883b8244b6a11a89de2c99f6d.zip
dev-python/django-tables2: bump to version 2.3.4
Also added python3_9 support. Closes: https://bugs.gentoo.org/767013 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-python/django-tables2/Manifest1
-rw-r--r--dev-python/django-tables2/django-tables2-2.3.4.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index c043d2e6711c..4ef458cb6ef1 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1 +1,2 @@
DIST django-tables2-2.2.1.tar.gz 71769 BLAKE2B 4f507b43907e2c0fd112f493d40681f13039e8a959c3ad4b3ea794dd08a3db24150263e880e79316aaafe59be7c4842504a496ee2e834eea68468c2a3ad0a297 SHA512 f5760f53d76af22033543757dd1b89876f9e40abcccc606bac1019fb10338c83884298a3f9feb280cfc03b209dfc551d07182ff0950c3cba9fafedd8371ecbce
+DIST django-tables2-2.3.4.tar.gz 77706 BLAKE2B 54e0903747ab29dab26049868f8cfd412d23fe3f36eaf292bebc90ee1c307f08d04af1eed469423e3699db227110fc0347a8034acb3b3b46971d37b3aebb84a1 SHA512 d10144b79850847d2787e4a97f450eb3709a419a5dcd330667e3746c16f3be7472c6c26dbf7d765356130b79b8c915c46fd3201c83e66806753f1bb95911895f
diff --git a/dev-python/django-tables2/django-tables2-2.3.4.ebuild b/dev-python/django-tables2/django-tables2-2.3.4.ebuild
new file mode 100644
index 000000000000..156016d10965
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.3.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9})
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="https://pypi.org/project/django-tables2/ https://github.com/bradleyayers/django-tables2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/django-1.11"
+DEPEND="${RDEPEND}"