summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 15:53:10 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 16:26:57 +0100
commit9a772433c506af95b65a28af6a82259dfb58dd03 (patch)
tree071205847628ab3b402914937c152b6aa68588f4
parentmedia-video/totem: Drop old (diff)
downloadgentoo-9a772433c506af95b65a28af6a82259dfb58dd03.tar.gz
gentoo-9a772433c506af95b65a28af6a82259dfb58dd03.tar.bz2
gentoo-9a772433c506af95b65a28af6a82259dfb58dd03.zip
app-crypt/gcr: Version bump
Package-Manager: portage-2.2.24
-rw-r--r--app-crypt/gcr/Manifest1
-rw-r--r--app-crypt/gcr/gcr-3.18.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-crypt/gcr/Manifest b/app-crypt/gcr/Manifest
index 21d53ace7647..0c16346e7b34 100644
--- a/app-crypt/gcr/Manifest
+++ b/app-crypt/gcr/Manifest
@@ -1,3 +1,4 @@
DIST gcr-3.12.2.tar.xz 1331884 SHA256 456e20615ab178aa92eeabdea64dcce535c10d5af189171d9375291a2447d21c SHA512 7c74302a4485e6909e39721b0beeeeb5920d218c4e8ab5a1878be33457f2b6d59df165bf2e6b606efc8275b8e45dffe8d28ac202cf835f7f2483237258a4d6b2 WHIRLPOOL 9655f1997ececce77f1b179f89798b5b9363ea94e0f2024772575ca05d88dd3b15432c1e0d69095b020726bc0fab1df023dfd6cc975488360f90e43fd9069a8c
DIST gcr-3.14.0.tar.xz 1340764 SHA256 2a2231147a01e2061f57fa9ca77557ff97bc6ceab028cee5528079f4b2fca63d SHA512 2538b2575c0d325587f8b5423ac6f9c522a69b415977398dc5c4330ce1de896c966e541eb6e536e87e81013bb2dedea4d0ae8baabdab9318db5b97e0977671b8 WHIRLPOOL 755842ad30608162bb81ed58a027a26be6d12ecb12e037b826841612c2481ea564f727e2bc4e03f13f8100257b2d2ee3dae213b56b5f04319718ff30c5eee2a9
DIST gcr-3.16.0.tar.xz 1335348 SHA256 ecfe8df41cc88158364bb15addc670b11e539fe844742983629ba2323888d075 SHA512 1db6e2532d2d0ceb6f339551b009baae5815fcf8a12b76b0eb9e13f301d1205c2e2c9b8f555ae011a84521e55fe9cccb703c3dd539d638b476e0474c34672be4 WHIRLPOOL 88a0d5936b6dd54923fd476f3af0acac9c068268416cb30c65670ae8bf8bec3940cdee84e72e6218c3cf9e59a023508e5961357b2e80a297428e573cddc6bd7b
+DIST gcr-3.18.0.tar.xz 1311368 SHA256 d4d16da5af55148a694055835ccd07ad34daf0ad03bdad929bf7cad15637ce00 SHA512 3733a462c23b0cf1d3579ea4b0b6eea9b5e3eb98e81e7c0e0364e540ec60a7a7bc567d1d159c674df280fb20c305cbaef796dffef73801ece4f4474352786e6b WHIRLPOOL 1bb299e386415c86dbb4f6afb48e365fd69e12a13e7349cefcd05c2685841fb0fb76c499780c2e275114c185a67b6be66989c6f989794ebbf1fd18ca501ed4b6
diff --git a/app-crypt/gcr/gcr-3.18.0.ebuild b/app-crypt/gcr/gcr-3.18.0.ebuild
new file mode 100644
index 000000000000..b19d1dddb174
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.18.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="https://git.gnome.org/browse/gcr"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-3
+IUSE="debug gtk +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=app-crypt/gnupg-2
+ >=app-crypt/p11-kit-0.19
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libgcrypt-1.2.2:0=
+ >=dev-libs/libtasn1-1:=
+ >=sys-apps/dbus-1
+ gtk? ( >=x11-libs/gtk+-3.12:3[X,introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-keyring-3.3
+"
+# gcr was part of gnome-keyring until 3.3
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection-common
+ dev-libs/libxslt
+ dev-libs/vala-common
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# eautoreconf needs:
+# dev-libs/gobject-introspection-common
+# dev-libs/vala-common
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Disable stupid flag changes
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_with gtk) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(usex debug --enable-debug=yes --enable-debug=default) \
+ --disable-update-icon-cache \
+ --disable-update-mime
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}