summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-03 21:00:51 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-03 21:39:17 +0200
commit9bc4f85609c4c642717d5d93ddb0ae47772d9a51 (patch)
treed21cc4ebd7a9a867312f71e0eb370d1646cccc35
parentprofiles/arch/arm64: Mask sys-devel/clang-runtime[crt] (diff)
downloadgentoo-9bc4f85609c4c642717d5d93ddb0ae47772d9a51.tar.gz
gentoo-9bc4f85609c4c642717d5d93ddb0ae47772d9a51.tar.bz2
gentoo-9bc4f85609c4c642717d5d93ddb0ae47772d9a51.zip
sys-devel/clang-runtime: Add USE=crt for (non-GCC) crt*.o files
-rw-r--r--sys-devel/clang-runtime/clang-runtime-4.0.1-r1.ebuild31
-rw-r--r--sys-devel/clang-runtime/clang-runtime-5.0.1-r1.ebuild31
-rw-r--r--sys-devel/clang-runtime/clang-runtime-6.0.0-r1.ebuild (renamed from sys-devel/clang-runtime/clang-runtime-6.0.0.ebuild)8
-rw-r--r--sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild8
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9999.ebuild8
-rw-r--r--sys-devel/clang-runtime/metadata.xml2
6 files changed, 85 insertions, 3 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-4.0.1-r1.ebuild b/sys-devel/clang-runtime/clang-runtime-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..34393f3f5c3f
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-4.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"
diff --git a/sys-devel/clang-runtime/clang-runtime-5.0.1-r1.ebuild b/sys-devel/clang-runtime/clang-runtime-5.0.1-r1.ebuild
new file mode 100644
index 000000000000..38aa2c0fe1f5
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-5.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"
diff --git a/sys-devel/clang-runtime/clang-runtime-6.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-6.0.0-r1.ebuild
index da0933c9b990..5fdd2d6b0a90 100644
--- a/sys-devel/clang-runtime/clang-runtime-6.0.0.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-6.0.0-r1.ebuild
@@ -12,13 +12,19 @@ SRC_URI=""
LICENSE="metapackage"
SLOT="${PV%_*}"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="+compiler-rt libcxx openmp +sanitize"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
RDEPEND="
compiler-rt? (
~sys-libs/compiler-rt-${PV}:${SLOT}
sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
)
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild
index 333b352d98bd..65baa4349d60 100644
--- a/sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild
@@ -13,13 +13,19 @@ LICENSE="metapackage"
# Note: keep it matching clang-9999 version
SLOT="6.0.0"
KEYWORDS=""
-IUSE="+compiler-rt libcxx openmp +sanitize"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
RDEPEND="
compiler-rt? (
~sys-libs/compiler-rt-${PV}:${SLOT}
sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
)
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/sys-devel/clang-runtime/clang-runtime-9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
index 5586ba0ef77f..dcd22734f007 100644
--- a/sys-devel/clang-runtime/clang-runtime-9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-9999.ebuild
@@ -13,13 +13,19 @@ LICENSE="metapackage"
# Note: keep it matching clang-9999 version
SLOT="7.0.0"
KEYWORDS=""
-IUSE="+compiler-rt libcxx openmp +sanitize"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
RDEPEND="
compiler-rt? (
~sys-libs/compiler-rt-${PV}:${SLOT}
sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
)
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/sys-devel/clang-runtime/metadata.xml b/sys-devel/clang-runtime/metadata.xml
index f761b620168e..bf616d36427c 100644
--- a/sys-devel/clang-runtime/metadata.xml
+++ b/sys-devel/clang-runtime/metadata.xml
@@ -6,6 +6,8 @@
</maintainer>
<use>
<flag name="compiler-rt">Install <pkg>sys-libs/compiler-rt</pkg> for -rtlib=compiler-rt</flag>
+ <flag name="crt">Require a package providing crt*.o files to make it possible to build
+ software without GCC installed</flag>
<flag name="libcxx">Install <pkg>sys-libs/libcxx</pkg> for -stdlib=libc++</flag>
<flag name="openmp">Install <pkg>sys-libs/libomp</pkg> for -fopenmp support</flag>
<flag name="sanitize">Enable compiler-rt sanitizer (-fsanitize*) support</flag>