summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-07 00:01:40 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-07 00:14:34 +0100
commit9bda0371de1cf8c5d094d63ea02cd884d4e83c32 (patch)
tree51563305bf942aaf4b4faa50a18ca63f11dba09b
parentdev-python/notebook: Bump to 6.1.5 (diff)
downloadgentoo-9bda0371de1cf8c5d094d63ea02cd884d4e83c32.tar.gz
gentoo-9bda0371de1cf8c5d094d63ea02cd884d4e83c32.tar.bz2
gentoo-9bda0371de1cf8c5d094d63ea02cd884d4e83c32.zip
dev-python/botocore: Bump to 1.19.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.13.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 18b8aeb3782c..639269390972 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,5 +4,6 @@ DIST botocore-1.18.18.tar.gz 6942407 BLAKE2B e58183d5aa79a210d82c1dc21806c9c86f9
DIST botocore-1.19.10.tar.gz 6973384 BLAKE2B dc0b1f45eda4cab8bbf56e45fc6f6134b9c23b485bae3eedb57f0773d8be0bd2cc1c3c291e0a1215383a56f519e17ad7848da889f355d9aef0194ed34303b3c0 SHA512 80f34dc31031b269af982fad8c62b8dbb7ee0fea7b91bfc63c9039e155ba55ad711167c5debd68306aab1f96e5761fae65303868fa2e4ecb17892be6baf24f2d
DIST botocore-1.19.11.tar.gz 6981193 BLAKE2B 8e7c799faef989817ce4cfbe26c359af0a8fc4c6997697d3ca669ec4bf273c2c8fd0cd2e8f5f044b77373d3fe81f69aa9c0d936f416876cc9efa860e04754dcd SHA512 650c2b4a7839312f3fb8450d61a521c0514c1f8e2a80835f2b5fa1f01c01675d53f18d1c5cd1e2c54aa520d6867820b85906649e64eaf9b56b143b7e1c7daca3
DIST botocore-1.19.12.tar.gz 6985286 BLAKE2B f65a416ecae9911899dc16411cc80a968e343531f43ded1b7f4c546df59d8f2cbb93d6027d07a267831ce71d27b53b9ac61ced2d91b69c94c344bed0167c64d7 SHA512 94d0d56dd5dc0c3dd3c28b6d9deb47949420778cbfaa30829db6a2787f3d8088327cb0194b920cee0598d7fc28936c4c0e532874449024485b27a06bf03982df
+DIST botocore-1.19.13.tar.gz 6985490 BLAKE2B 2da3b5840c18e7ec1bcdf9b535defc9ba5d1b0990febdbc6bfbe3aaadfb81b754d2a9df76aa3978279dee22af35a50da6cda186d1d632403dbb60208fec216f5 SHA512 74323c87a9a6e6009862d11f5e96dfb5d2cde282aca206a1703038f001d926d282fdb6cce9085c8645bc4e1b2cff1666cbf013a508b3aa3cb598cdd74c476b6b
DIST botocore-1.19.8.tar.gz 6970481 BLAKE2B 52d3f8ee7dc38feddb3f7799959624b4baf4b75ebcf3ad8257c25ad13b8a8c3cf526ee187681b6d8f5f6ee874071a02c59bd106cb4b4e23ad9cf13b9aa74deef SHA512 845dfec33f63deee44bfffe81801995bfcc2014880c2d520b927421219279107b0fe44dc84425c0a55ddec73d5ad8aeb34f2b84178e1365d137240a2e94370c7
DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.13.ebuild b/dev-python/botocore/botocore-1.19.13.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.13.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}