summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-17 00:18:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-17 00:40:33 +0100
commit9ec8e2b3e611fbb2a32e28c634b01711c89d114a (patch)
treeda4a230e0b5a315d1442d6901e4c514dcf082e2e
parentkde-frameworks/kinit: drop 5.75.0* (diff)
downloadgentoo-9ec8e2b3e611fbb2a32e28c634b01711c89d114a.tar.gz
gentoo-9ec8e2b3e611fbb2a32e28c634b01711c89d114a.tar.bz2
gentoo-9ec8e2b3e611fbb2a32e28c634b01711c89d114a.zip
kde-frameworks/kio: drop 5.75.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kio/Manifest1
-rw-r--r--kde-frameworks/kio/files/kio-5.75.0-fix-special-char-file-selection.patch201
-rw-r--r--kde-frameworks/kio/kio-5.75.0-r1.ebuild96
3 files changed, 0 insertions, 298 deletions
diff --git a/kde-frameworks/kio/Manifest b/kde-frameworks/kio/Manifest
index 056646dc0b36..9316ae4d3771 100644
--- a/kde-frameworks/kio/Manifest
+++ b/kde-frameworks/kio/Manifest
@@ -1,3 +1,2 @@
DIST kio-5.74.1.tar.xz 3281248 BLAKE2B 584fde1483477b70ee7892bf0de37aedb62672c2ada57d85c9646894606f10b6a03750030e1926441707b12b18ece167fa3a0dbbb75a8155bddfd35342d372f8 SHA512 a563b939d2bc71443c6c748ddf293fab84072efebdcea639707d7aaf2739356a906668be3dca915464ce7c81b63d7482ac024df786e04bbafcf999cde5ebc5e2
-DIST kio-5.75.0.tar.xz 3277424 BLAKE2B ac7d4dafb00ca2c16ddbb6a45d0a5e07d61f5d0a9c2d2b26a8347dee7ff23fabdec2184437e7ad14f02c1def3af5778b599d64e0eff3780ae93aca0a9b43896c SHA512 028e4de5897fb61fda7bf80b0d2ccb022bb7df936648ba3429623708b108df8081bf1b0f416097c3658d1cd4b1a96757010d32ab5a9b382195b6915040ed5a06
DIST kio-5.76.0.tar.xz 3301808 BLAKE2B 4bb2c7c1d2867155ca35bf9c3b80cef7e96e8ca651adb2fc46d5e7beca44c80e440a7ee2f6caf1f1cacfec15e9c4997f86fa66dc6efed45d99804f8c285de6a9 SHA512 3b7167b7452629ef6f43bf52cf1e1d11daae36dd9a7a0f22844ea08f362e1e40f14ea1983fcf7e10bf12c40fdfcfee9f3eef66b73bd2f34a83d9dd37de23f869
diff --git a/kde-frameworks/kio/files/kio-5.75.0-fix-special-char-file-selection.patch b/kde-frameworks/kio/files/kio-5.75.0-fix-special-char-file-selection.patch
deleted file mode 100644
index 74ffc55207d7..000000000000
--- a/kde-frameworks/kio/files/kio-5.75.0-fix-special-char-file-selection.patch
+++ /dev/null
@@ -1,201 +0,0 @@
-From 4321b8ff8ac7a8ffdea1068d8bbc734a0a34c0d0 Mon Sep 17 00:00:00 2001
-From: Andreas Bontozoglou <a.bontozoglou@gmail.com>
-Date: Wed, 14 Oct 2020 15:01:02 +0100
-Subject: [PATCH] [BUG] Fixing regression on selecting files that contain `#`
-
-Introduced in tokenize() in https://invent.kde.org/frameworks/kio/-/merge_requests/89.
-Fixing by using setPath and adding test-case for parsing such filenames.
----
- autotests/kfilewidgettest.cpp | 37 +++++++++++++++++++--------------
- src/filewidgets/kfilewidget.cpp | 31 +++++++++++++++------------
- 2 files changed, 39 insertions(+), 29 deletions(-)
-
-diff --git a/autotests/kfilewidgettest.cpp b/autotests/kfilewidgettest.cpp
-index 859ea958..ac34e387 100644
---- a/autotests/kfilewidgettest.cpp
-+++ b/autotests/kfilewidgettest.cpp
-@@ -24,6 +24,7 @@
- #include <QAbstractItemView>
- #include <QDropEvent>
- #include <QMimeData>
-+#include <QStringList>
- #include <QStringLiteral>
- #include <QList>
- #include <QUrl>
-@@ -530,58 +531,62 @@ private Q_SLOTS:
- }
-
- void testTokenize_data()
-- {
-- // Real filename (as in how they are stored in the fs)
-- QTest::addColumn<QList<QString>>("fileNames");
-+ {
-+ // Real filename (as in how they are stored in the fs)
-+ QTest::addColumn<QStringList>("fileNames");
- // Escaped value of the text-box in the dialog
- QTest::addColumn<QString>("expectedCurrentText");
-
-- QTest::newRow("simple") << QList<QString>{"test2"} << QString("test2");
-+ QTest::newRow("simple") << QStringList{"test2"} << QString("test2");
-
- // When a single file with space is selected, it is _not_ quoted ...
-- QTest::newRow("space-single-file")
-- << QList<QString>{"test space"}
-+ QTest::newRow("space-single-file")
-+ << QStringList{"test space"}
- << QString("test space");
-
- // However, when multiple files are selected, they are quoted
- QTest::newRow("space-multi-file")
-- << QList<QString>{"test space", "test2"}
-+ << QStringList{"test space", "test2"}
- << QString("\"test space\" \"test2\"");
-
- // All quotes in names should be escaped, however since this is a single
- // file, the whole name will not be escaped.
- QTest::newRow("quote-single-file")
-- << QList<QString>{"test\"quote"}
-+ << QStringList{"test\"quote"}
- << QString("test\\\"quote");
--
-+
- // Escape multiple files. Files should also be wrapped in ""
- // Note that we are also testing quote at the end of the name
- QTest::newRow("quote-multi-file")
-- << QList<QString>{"test\"quote", "test2-quote\"", "test"}
-+ << QStringList{"test\"quote", "test2-quote\"", "test"}
- << QString("\"test\\\"quote\" \"test2-quote\\\"\" \"test\"");
-
- // Ok, enough with quotes... lets do some backslashes
- // Backslash literals in file names - Unix only case
- QTest::newRow("backslash-single-file")
-- << QList<QString>{"test\\backslash"}
-+ << QStringList{"test\\backslash"}
- << QString("test\\\\backslash");
-
- QTest::newRow("backslash-multi-file")
-- << QList<QString>{"test\\back\\slash", "test"}
-+ << QStringList{"test\\back\\slash", "test"}
- << QString("\"test\\\\back\\\\slash\" \"test\"");
-
- QTest::newRow("double-backslash-multi-file")
-- << QList<QString>{"test\\\\back\\slash", "test"}
-+ << QStringList{"test\\\\back\\slash", "test"}
- << QString("\"test\\\\\\\\back\\\\slash\" \"test\"");
-
- QTest::newRow("double-backslash-end")
-- << QList<QString>{"test\\\\"}
-+ << QStringList{"test\\\\"}
- << QString("test\\\\\\\\");
-
- QTest::newRow("single-backslash-end")
-- << QList<QString>{"some thing", "test\\"}
-+ << QStringList{"some thing", "test\\"}
- << QString("\"some thing\" \"test\\\\\"");
-
-+ QTest::newRow("sharp")
-+ << QStringList{"some#thing"}
-+ << QString("some#thing");
-+
- }
-
- void testTokenize()
-@@ -589,7 +594,7 @@ private Q_SLOTS:
- // We will use setSelectedUrls([QUrl]) here in order to check correct
- // filename escaping. Afterwards we will accept() the dialog to confirm
- // correct result
-- QFETCH(QList<QString>, fileNames);
-+ QFETCH(QStringList, fileNames);
- QFETCH(QString, expectedCurrentText);
-
- QTemporaryDir tempDir;
-diff --git a/src/filewidgets/kfilewidget.cpp b/src/filewidgets/kfilewidget.cpp
-index 1bbf3e58..32ca0617 100644
---- a/src/filewidgets/kfilewidget.cpp
-+++ b/src/filewidgets/kfilewidget.cpp
-@@ -789,8 +789,8 @@ static QString relativePathOrUrl(const QUrl &baseUrl, const QUrl &url);
- /**
- * Escape the given Url so that is fit for use in the selected list of file. This
- * mainly handles double quote (") characters. These are used to separate entries
-- * in the list, however, if `"` appears in the filename (or path), this will be
-- * escaped as `\"`. Later, the tokenizer is able to understand the difference
-+ * in the list, however, if `"` appears in the filename (or path), this will be
-+ * escaped as `\"`. Later, the tokenizer is able to understand the difference
- * and do the right thing
- */
- static QString escapeDoubleQuotes(QString && path);
-@@ -1623,7 +1623,7 @@ void KFileWidget::setSelectedUrl(const QUrl &url)
- }
-
- void KFileWidget::setSelectedUrls(const QList<QUrl> &urls)
--{
-+{
- if (urls.isEmpty()) {
- return;
- }
-@@ -1717,7 +1717,7 @@ QList<QUrl> KFileWidget::selectedUrls() const
-
- QList<QUrl> KFileWidgetPrivate::tokenize(const QString &line) const
- {
-- qCDebug(KIO_KFILEWIDGETS_FW) << "Tokenizing:" << line;
-+ qCDebug(KIO_KFILEWIDGETS_FW) << "Tokenizing:" << line;
-
- QList<QUrl> urls;
- QUrl u(ops->url().adjusted(QUrl::RemoveFilename));
-@@ -1727,15 +1727,21 @@ QList<QUrl> KFileWidgetPrivate::tokenize(const QString &line) const
-
- // A helper that creates, validates and appends a new url based
- // on the given filename.
-- auto addUrl = [u, &urls](const QString & partial_name)
-- {
-+ auto addUrl = [u, &urls](const QString &partial_name)
-+ {
- if (partial_name.trimmed().isEmpty()) {
- return;
- }
-
-+ // We have to use setPath here, so that something like "test#file"
-+ // isn't interpreted to have path "test" and fragment "file".
-+ QUrl partial_url;
-+ partial_url.setPath(partial_name);
-+
- // This returns QUrl(partial_name) for absolute URLs.
- // Otherwise, returns the concatenated url.
-- QUrl finalUrl = u.resolved(QUrl(partial_name));
-+ const QUrl finalUrl = u.resolved(partial_url);
-+
- if (finalUrl.isValid()) {
- urls.append(finalUrl);
- } else {
-@@ -1758,7 +1764,7 @@ QList<QUrl> KFileWidgetPrivate::tokenize(const QString &line) const
- escape = false;
- continue;
- }
--
-+
- // Handle escape start
- if (ch.toLatin1() == '\\') {
- escape = true;
-@@ -1777,15 +1783,14 @@ QList<QUrl> KFileWidgetPrivate::tokenize(const QString &line) const
- partial_name += ch;
- }
-
-- // Handle the last item which is buffered in
-- // partial_name. This is required for single-file
-- // selection dialogs since the name will not be
-- // wrapped in quotes
-+ // Handle the last item which is buffered in partial_name. This is
-+ // required for single-file selection dialogs since the name will not
-+ // be wrapped in quotes
- if (!partial_name.isEmpty()) {
- addUrl(partial_name);
- partial_name.clear();
- }
--
-+
- return urls;
- }
-
---
-GitLab
-
diff --git a/kde-frameworks/kio/kio-5.75.0-r1.ebuild b/kde-frameworks/kio/kio-5.75.0-r1.ebuild
deleted file mode 100644
index 310bd84b0a4b..000000000000
--- a/kde-frameworks/kio/kio-5.75.0-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_DESIGNERPLUGIN="true"
-ECM_TEST="forceoptional"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.14.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org xdg-utils
-
-DESCRIPTION="Framework providing transparent file and data management"
-LICENSE="LGPL-2+"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="acl +handbook kerberos +kwallet X"
-
-# drop qtnetwork subslot operator when QT_MINIMAL >= 5.15.0
-RDEPEND="
- dev-libs/libxml2
- dev-libs/libxslt
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5=[ssl]
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- =kde-frameworks/kauth-${PVCUT}*:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kbookmarks-${PVCUT}*:5
- =kde-frameworks/kcodecs-${PVCUT}*:5
- =kde-frameworks/kcompletion-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kconfigwidgets-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/kcrash-${PVCUT}*:5
- =kde-frameworks/kdbusaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kitemviews-${PVCUT}*:5
- =kde-frameworks/kjobwidgets-${PVCUT}*:5
- =kde-frameworks/knotifications-${PVCUT}*:5
- =kde-frameworks/kservice-${PVCUT}*:5
- =kde-frameworks/ktextwidgets-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kwindowsystem-${PVCUT}*:5
- =kde-frameworks/kxmlgui-${PVCUT}*:5
- =kde-frameworks/solid-${PVCUT}*:5
- acl? (
- sys-apps/attr
- virtual/acl
- )
- handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
- kerberos? ( virtual/krb5 )
- kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
- X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
-"
-DEPEND="${RDEPEND}
- >=dev-qt/qtconcurrent-${QTMIN}:5
- test? ( sys-libs/zlib )
- X? (
- x11-base/xorg-proto
- x11-libs/libX11
- x11-libs/libXrender
- )
-"
-PDEPEND="
- >=kde-frameworks/kded-${PVCUT}:5
-"
-
-# tests hang
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-special-char-file-selection.patch )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package acl ACL)
- $(cmake_use_find_package handbook KF5DocTools)
- $(cmake_use_find_package kerberos GSSAPI)
- $(cmake_use_find_package kwallet KF5Wallet)
- $(cmake_use_find_package X X11)
- )
-
- ecm_src_configure
-}
-
-pkg_postinst() {
- ecm_pkg_postinst
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- ecm_pkg_postrm
- xdg_desktop_database_update
-}