summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-01-09 11:30:26 +0100
committerUltrabug <ultrabug@gentoo.org>2018-01-11 12:34:12 +0100
commit9ef71bd8c965fe26ba310494a615fb8835be12a4 (patch)
tree0deb43c57717d452bce65a1ac20396072249e34a
parentdev-db/pgtap: Cleanup (diff)
downloadgentoo-9ef71bd8c965fe26ba310494a615fb8835be12a4.tar.gz
gentoo-9ef71bd8c965fe26ba310494a615fb8835be12a4.tar.bz2
gentoo-9ef71bd8c965fe26ba310494a615fb8835be12a4.zip
dev-db/mongodb: reintroduce scons fixes
Closes: https://bugs.gentoo.org/643984 Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6804
-rw-r--r--dev-db/mongodb/files/mongodb-3.6.1-fix-scons.patch32
-rw-r--r--dev-db/mongodb/mongodb-3.6.1-r1.ebuild (renamed from dev-db/mongodb/mongodb-3.6.1.ebuild)1
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/mongodb/files/mongodb-3.6.1-fix-scons.patch b/dev-db/mongodb/files/mongodb-3.6.1-fix-scons.patch
new file mode 100644
index 000000000000..d7bfb35b00d5
--- /dev/null
+++ b/dev-db/mongodb/files/mongodb-3.6.1-fix-scons.patch
@@ -0,0 +1,32 @@
+diff --git a/SConstruct b/SConstruct
+index fe7975b..92659a7 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1619,7 +1619,6 @@ if env.TargetOSIs('posix'):
+ # -Winvalid-pch Warn if a precompiled header (see Precompiled Headers) is found in the search path but can't be used.
+ env.Append( CCFLAGS=["-fno-omit-frame-pointer",
+ "-fno-strict-aliasing",
+- "-ggdb",
+ "-pthread",
+ "-Wall",
+ "-Wsign-compare",
+@@ -1631,6 +1630,8 @@ if env.TargetOSIs('posix'):
+ env.Append( CCFLAGS=["-Werror"] )
+
+ env.Append( CXXFLAGS=["-Woverloaded-virtual"] )
++ env.Append( CXXFLAGS=os.environ['CXXFLAGS'] )
++ env.Append( LINKFLAGS=os.environ['LDFLAGS'] )
+ if env.ToolchainIs('clang'):
+ env.Append( CXXFLAGS=['-Werror=unused-result'] )
+
+@@ -1650,8 +1651,8 @@ if env.TargetOSIs('posix'):
+
+ env.Append( LIBS=[] )
+
+- #make scons colorgcc friendly
+- for key in ('HOME', 'TERM'):
++ #make scons colorgcc, distcc, ccache friendly
++ for key in ('HOME', 'PATH', 'TERM'):
+ try:
+ env['ENV'][key] = os.environ[key]
+ except KeyError:
diff --git a/dev-db/mongodb/mongodb-3.6.1.ebuild b/dev-db/mongodb/mongodb-3.6.1-r1.ebuild
index 363620ef0504..8291fe7fc50d 100644
--- a/dev-db/mongodb/mongodb-3.6.1.ebuild
+++ b/dev-db/mongodb/mongodb-3.6.1-r1.ebuild
@@ -52,6 +52,7 @@ PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"
PATCHES=(
"${FILESDIR}/${PN}-3.4.7-no-boost-check.patch"
+ "${FILESDIR}/${PN}-3.6.1-fix-scons.patch"
"${FILESDIR}/${PN}-3.6.1-no-compass.patch"
)