summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-25 20:35:41 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-25 22:05:01 -0400
commit9f8fbe18900b6daa8d7cb58b7019fd14802b83f2 (patch)
treec9cec090d1bc4776812824be0a02ca240ac34477
parentnet-wireless/gobi_loader: bump EAPI and drop eutils (diff)
downloadgentoo-9f8fbe18900b6daa8d7cb58b7019fd14802b83f2.tar.gz
gentoo-9f8fbe18900b6daa8d7cb58b7019fd14802b83f2.tar.bz2
gentoo-9f8fbe18900b6daa8d7cb58b7019fd14802b83f2.zip
app-text/aiksaurus: bump EAPI and drop eutils
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-text/aiksaurus/aiksaurus-1.2.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-text/aiksaurus/aiksaurus-1.2.1.ebuild b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
index d359b259e030..fcf08e959e71 100644
--- a/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
+++ b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit flag-o-matic eutils libtool
+EAPI=6
+inherit flag-o-matic libtool
DESCRIPTION="A thesaurus lib, tool and database"
HOMEPAGE="https://sourceforge.net/projects/aiksaurus"
@@ -17,9 +17,10 @@ RDEPEND="gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}
gtk? ( virtual/pkgconfig )"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch #214248
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+src_prepare() {
+ default
# Needed to make relink work on FreeBSD, without it won't install.
# Also needed for a sane .so versionning there.
elibtoolize
@@ -32,5 +33,4 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS README* ChangeLog
}