summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-19 04:42:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-19 04:44:29 +0200
commit9fc6db41615603fb8bd927c09e4c28c4de8fb389 (patch)
tree3819694cb0adc222b3d5fd3f94f37b089e0a5399
parentdev-python/unearth: Remove old (diff)
downloadgentoo-9fc6db41615603fb8bd927c09e4c28c4de8fb389.tar.gz
gentoo-9fc6db41615603fb8bd927c09e4c28c4de8fb389.tar.bz2
gentoo-9fc6db41615603fb8bd927c09e4c28c4de8fb389.zip
dev-python/unearth: Bump to 0.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/unearth/Manifest1
-rw-r--r--dev-python/unearth/unearth-0.15.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index 0e5b18bc4937..670fc64e28f4 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1 +1,2 @@
DIST unearth-0.15.1.tar.gz 283687 BLAKE2B e43a0fac6023974c877ad7b82eac402d38da61920ab905587bf19d6e506b127785863ae45064392ddfee042e3fa12868d996c4375acbd1baa7c31402d31da80a SHA512 94db664b45f6e570437a0e24ba12c0c8ac6358ef5fda214bcd2f5665158f4e314a23f77dcc5f923804a7b8a30e0c580c3efae854ee5a502504b48db405d932fb
+DIST unearth-0.15.2.tar.gz 283748 BLAKE2B 8387454676d6253ba1df6cf2c857d416c5b67ac5c9deafb6b34a70263f07147688f12c8bbd4a76dbca6a98542ccb31233d9ad19260f7800bcc67491ab0b76500 SHA512 1763d640153b53ce18b5b7c0ccab811402fe8dade87ebe64bf8984284710fc739c9ef0d0df20e7be356f4e93dda126bec3d6d801c92ad2c5b5381f8d6f94c04e
diff --git a/dev-python/unearth/unearth-0.15.2.ebuild b/dev-python/unearth/unearth-0.15.2.ebuild
new file mode 100644
index 000000000000..5260d38a7421
--- /dev/null
+++ b/dev-python/unearth/unearth-0.15.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.27.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -p pytest_mock
+}