summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-16 21:00:44 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-16 21:03:13 +0200
commita05ed6ed30b2d87d1e7d8711cb8060a6fa715c39 (patch)
tree7912acd5ccb2beb11b5a65f7232eed8eda0c9884
parentsys-apps/uam: Switch to GitHub (diff)
downloadgentoo-a05ed6ed30b2d87d1e7d8711cb8060a6fa715c39.tar.gz
gentoo-a05ed6ed30b2d87d1e7d8711cb8060a6fa715c39.tar.bz2
gentoo-a05ed6ed30b2d87d1e7d8711cb8060a6fa715c39.zip
sys-apps/uam: Bump to EAPI 6
-rw-r--r--sys-apps/uam/uam-0.3.2-r1.ebuild44
-rw-r--r--sys-apps/uam/uam-9999.ebuild11
2 files changed, 51 insertions, 4 deletions
diff --git a/sys-apps/uam/uam-0.3.2-r1.ebuild b/sys-apps/uam/uam-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..409fc7f68e81
--- /dev/null
+++ b/sys-apps/uam/uam-0.3.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit udev user
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="https://github.com/mgorny/uam/"
+SRC_URI="https://github.com/mgorny/uam/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
+ elog "to enable in-kernel media polling, e.g.:"
+ elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
+ elog "where 5000 would mean a poll will occur every 5 seconds."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool."
+
+ udev_reload
+}
diff --git a/sys-apps/uam/uam-9999.ebuild b/sys-apps/uam/uam-9999.ebuild
index 5b6acde55b38..4aa949336985 100644
--- a/sys-apps/uam/uam-9999.ebuild
+++ b/sys-apps/uam/uam-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils git-r3 udev user
+inherit autotools git-r3 udev user
DESCRIPTION="Simple udev-based automounter for removable USB media"
HOMEPAGE="https://github.com/mgorny/uam/"
@@ -21,6 +19,11 @@ RDEPEND="virtual/udev"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ default
+ eautoreconf
+}
+
pkg_postinst() {
# The plugdev group is created by pam, pmount and many other ebuilds
# in gx86. As we don't want to depend on any of them (even pmount is