summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-23 20:37:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-23 21:11:21 +0200
commita156be56ab28fc22be7c9d03d4543151aa6e275b (patch)
tree58de79cdd6289debb14c1f5198228a026e9253e5
parentsys-libs/tdb: Removed old. (diff)
downloadgentoo-a156be56ab28fc22be7c9d03d4543151aa6e275b.tar.gz
gentoo-a156be56ab28fc22be7c9d03d4543151aa6e275b.tar.bz2
gentoo-a156be56ab28fc22be7c9d03d4543151aa6e275b.zip
sys-libs/ldb: Bump to version 2.0.5
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-libs/ldb/Manifest1
-rw-r--r--sys-libs/ldb/ldb-2.0.5.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/sys-libs/ldb/Manifest b/sys-libs/ldb/Manifest
index db0b4ee53c76..eed9148127a3 100644
--- a/sys-libs/ldb/Manifest
+++ b/sys-libs/ldb/Manifest
@@ -11,3 +11,4 @@ DIST ldb-1.5.4.tar.gz 1629123 BLAKE2B 3c71af079f2e5cb81e493d16d453c53bd0ee4c6372
DIST ldb-1.5.5.tar.gz 1629070 BLAKE2B 374042c77c9ec7bd88ad1d97757f171ae831a630751fc06bf22190355c1448fa8c2327d308cdbe5b46ca21236738548d2c1041c3dfb428e1dfee8053edf90050 SHA512 562e08b3d6564d08fed80dc43ca299c38fbd958dbe27ed1400e5eb5c3df0f4c7b7eaf502b13eec5544b168f26c5e6537615f65e28dcaeb6473d2ff3c3c7a4e4b
DIST ldb-1.6.2.tar.gz 1629794 BLAKE2B 5219479c773aa87c4bd6917e60b963df9cf3c481468ed020b4e9c4a175110ce80fd1c7a4ca4e28d99c972e0891287485261310eab1bbd7b8b138ea59f168ac8c SHA512 089dee2465efe0811ff745b52b15d2d7638b940112a06680706d5401231864859605ff0392245d4c815e9b85f5a4ba782fc61d8dba215cc8198e7d9a6ddd255e
DIST ldb-1.6.3.tar.gz 1628668 BLAKE2B e9b6535eddf49496151e544f6879641c58a614f6de95463f7d0bf1953744953a5d55dde935d39b690d4c87e66914d8de0f0f5d4816a61fdecc81f8797584013e SHA512 a41b1fd2afa9a02dec37519f28e0e720b649c2a0aa6caebeb6697dbefdc6a055ef26500c5ccb0439b495d8c03218920b389fb9601d1cf5ca4d5046f192a5fefd
+DIST ldb-2.0.5.tar.gz 1669846 BLAKE2B d68046b385955c376118cb60e16939115332d88e8e67d157029397915c3e8f3d754abc9d93c64250ce990f7b82fb3947bdf5fba0f6f8bc457bc6dfd08e8bc534 SHA512 de9325f8bdd9ac782b3f8633444780f4aaa030e2c74c643220e845d9a779f8c8e174f0b9d9d8668de028cb832eb9d81965cb8e4471d90f9344dc48877a3abbe8
diff --git a/sys-libs/ldb/ldb-2.0.5.ebuild b/sys-libs/ldb/ldb-2.0.5.ebuild
new file mode 100644
index 000000000000..d6605ba80356
--- /dev/null
+++ b/sys-libs/ldb/ldb-2.0.5.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-single-r1 waf-utils multilib-minimal eutils
+
+DESCRIPTION="An LDAP-like embedded database"
+HOMEPAGE="https://ldb.samba.org"
+SRC_URI="https://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc +ldap +lmdb python"
+
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ dev-libs/popt[${MULTILIB_USEDEP}]
+ >=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
+ >=sys-libs/talloc-2.2.0[python?,${MULTILIB_USEDEP}]
+ >=sys-libs/tdb-1.4.1[python?,${MULTILIB_USEDEP}]
+ >=sys-libs/tevent-0.10.0[python(+)?,${MULTILIB_USEDEP}]
+ ldap? ( net-nds/openldap )
+ lmdb? ( >=dev-db/lmdb-0.9.16[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="dev-libs/libxslt
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/pyldb.h )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.2-optional_packages.patch
+ "${FILESDIR}"/${PN}-1.1.31-fix_PKGCONFIGDIR-when-python-disabled.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(usex ldap '' --disable-ldap)
+ $(usex lmdb '' --without-ldb-lmdb)
+ --disable-rpath
+ --disable-rpath-install --bundled-libraries=NONE
+ --with-modulesdir="${EPREFIX}"/usr/$(get_libdir)/samba
+ --builtin-libraries=NONE
+ )
+ if ! multilib_is_native_abi; then
+ myconf+=( --disable-python )
+ else
+ use python || myconf+=( --disable-python )
+ fi
+ waf-utils_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile(){
+ waf-utils_src_compile
+ multilib_is_native_abi && use doc && doxygen Doxyfile
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ WAF_MAKE=1 \
+ PATH=buildtools/bin:../../../buildtools/bin:$PATH:"${BUILD_DIR}"/bin/shared/private/ \
+ LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${BUILD_DIR}"/bin/shared/private/:"${BUILD_DIR}"/bin/shared \
+ waf test || die
+ fi
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ if multilib_is_native_abi && use doc; then
+ doman apidocs/man/man3/*.3
+ docinto html
+ dodoc -r apidocs/html/*
+ fi
+}
+
+pkg_postinst() {
+ if has_version sys-auth/sssd; then
+ ewarn "You have sssd installed. It is known to break after ldb upgrades,"
+ ewarn "so please try to rebuild it before reporting bugs."
+ ewarn "See https://bugs.gentoo.org/404281"
+ fi
+}