summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-11 15:14:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-11 15:18:21 +0100
commita21ffc68b96c51c49c0d6f4299f2d5efd69bfacf (patch)
treea11a8e0e806d32373585377d20e878e6a5bccb3d
parentapp-shells/mksh: Version cleanup, <57-r2 (diff)
downloadgentoo-a21ffc68b96c51c49c0d6f4299f2d5efd69bfacf.tar.gz
gentoo-a21ffc68b96c51c49c0d6f4299f2d5efd69bfacf.tar.bz2
gentoo-a21ffc68b96c51c49c0d6f4299f2d5efd69bfacf.zip
sci-misc/repsnapper: Remove last-rited package
Closes: https://bugs.gentoo.org/649066 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--profiles/package.mask1
-rw-r--r--sci-misc/repsnapper/Manifest3
-rw-r--r--sci-misc/repsnapper/files/repsnapper-2.4a_p0-gcc6.patch54
-rw-r--r--sci-misc/repsnapper/files/std-c11.patch31
-rw-r--r--sci-misc/repsnapper/metadata.xml8
-rw-r--r--sci-misc/repsnapper/repsnapper-2.3.2a_p3.ebuild33
-rw-r--r--sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild36
-rw-r--r--sci-misc/repsnapper/repsnapper-2.4a_p3.ebuild34
-rw-r--r--sci-misc/repsnapper/repsnapper-9999.ebuild29
9 files changed, 0 insertions, 229 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index cdf1ec207efb..90c729aa57f3 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -596,7 +596,6 @@ media-libs/qimageblitz
# Ancient, blocks x11-libs/gtkglext cleanup, open bug #649066
# Masked for removal in 30 days.
dev-cpp/gtkglextmm
-sci-misc/repsnapper
# Michał Górny <mgorny@gentoo.org> (2020-01-12)
# Python 2 only, depends on OpenStack which is Py3 now. No release
diff --git a/sci-misc/repsnapper/Manifest b/sci-misc/repsnapper/Manifest
deleted file mode 100644
index 748c922283e4..000000000000
--- a/sci-misc/repsnapper/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST repsnapper-2.3.2a3.tar.gz 1344447 BLAKE2B 31fdfe0cb6c7b6c9358ecef1a8fc82cbfa82c337b6120e605bd103e5f5236780add8aa40308695adfd65c619b7174a4e7bcf35442950aaaac2eb2bda9a993c58 SHA512 f68510baefb898954f58aa5e35909b8215edcd8ee74028e717ad97293091f4b323628ca0ba80ff685d1aef0db4785a2887986b89a95769a70f8f23ab031dafa4
-DIST repsnapper-2.4a0.tar.gz 888457 BLAKE2B 5c554c6dae2a3d6fede6c0fa86bd9b4ddac00530c466f1b8b0f20b3ac5e129677a18d9020cf0c1e80eb930040319a3e28609b43d282971fdbb937cc601fe2374 SHA512 b79c51f53ae29d09f5a328366c10b9e775d396f6da0ef24aa71b522fbd718af2f658700838f64ba01ce9c5cab90e39960b0ca5ed2554f802ff37ef258ae89031
-DIST repsnapper-2.4a3.tar.gz 888546 BLAKE2B c9934c337ea2f46a74342f1ce935b00d34a6242304bb6779dc1ae4bdb959c39c3e0162f1fce8aad73681fd937eb43145fbfc4c5de404e290ee77e1f6874734af SHA512 ebe586a9212edbf699444a9c89b25702facd1018751658b831e9e662cd1bc2c54e6827802c0d89055c2882cef7db343bf036c08a9a1fc28bc66acee895bca6aa
diff --git a/sci-misc/repsnapper/files/repsnapper-2.4a_p0-gcc6.patch b/sci-misc/repsnapper/files/repsnapper-2.4a_p0-gcc6.patch
deleted file mode 100644
index 80a3c56eb86b..000000000000
--- a/sci-misc/repsnapper/files/repsnapper-2.4a_p0-gcc6.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From f6a411fa829f144800d123c1256d7d7648736437 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Tiago=20St=C3=BCrmer=20Daitx?= <tdaitx@gmail.com>
-Date: Thu, 1 Sep 2016 00:02:48 -0300
-Subject: [PATCH 1/2] replace abs() with std::abs() for gcc6 compatibility
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Building with GCC 6 fails with "call of overloaded ‘abs(double)’ is
-ambiguous" - for some reason only on PowerPC and PPC64.
----
- libraries/amf/amftools-code/include/STL_File.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libraries/amf/amftools-code/include/STL_File.h b/libraries/amf/amftools-code/include/STL_File.h
-index 0bc01bed..2d9d656f 100644
---- a/libraries/amf/amftools-code/include/STL_File.h
-+++ b/libraries/amf/amftools-code/include/STL_File.h
-@@ -89,7 +89,7 @@ class aWeldVertex {
- Vec3D v;
- int OrigIndex;
-
-- static inline bool IsSoftLessThan(const aWeldVertex& v1, const aWeldVertex& v2){if(abs(v1.v.z - v2.v.z) <= WeldThresh){ if(abs(v1.v.y - v2.v.y) <= WeldThresh){ return v1.v.x < v2.v.x-WeldThresh;}else return (v1.v.y < v2.v.y-WeldThresh);} else return (v1.v.z < v2.v.z-WeldThresh); } //Is less then (generates a "hash" for sorting vertices by z for set
-+ static inline bool IsSoftLessThan(const aWeldVertex& v1, const aWeldVertex& v2){if(std::abs(v1.v.z - v2.v.z) <= WeldThresh){ if(std::abs(v1.v.y - v2.v.y) <= WeldThresh){ return v1.v.x < v2.v.x-WeldThresh;}else return (v1.v.y < v2.v.y-WeldThresh);} else return (v1.v.z < v2.v.z-WeldThresh); } //Is less then (generates a "hash" for sorting vertices by z for set
- static double WeldThresh; //weld threshold for importing from STL
- };
-
-
-From 93c81e3794a3eb7c2b7c7611803a3107fb25027b Mon Sep 17 00:00:00 2001
-From: "Ying-Chun Liu (PaulLiu)" <paulliu@debian.org>
-Date: Wed, 4 Jan 2017 13:50:56 +0800
-Subject: [PATCH 2/2] Fix FTBFS for glibmm Glib::RefPtr
-
-Now we can use operator RefPtr::operator bool() to test if it is NULL.
-RefPtr::operator== can not work on int.
-
-Signed-off-by: Ying-Chun Liu (PaulLiu) <paulliu@debian.org>
----
- src/model.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/model.cpp b/src/model.cpp
-index ee559c47..22f0bb39 100644
---- a/src/model.cpp
-+++ b/src/model.cpp
-@@ -181,7 +181,7 @@ vector<Shape*> Model::ReadShapes(Glib::RefPtr<Gio::File> file,
- uint max_triangles)
- {
- vector<Shape*> shapes;
-- if (file==0) return shapes;
-+ if (!file) return shapes;
- File sfile(file);
- vector< vector<Triangle> > triangles;
- vector<ustring> shapenames;
diff --git a/sci-misc/repsnapper/files/std-c11.patch b/sci-misc/repsnapper/files/std-c11.patch
deleted file mode 100644
index a8ff67ae3878..000000000000
--- a/sci-misc/repsnapper/files/std-c11.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/slicer/poly.cpp.orig 2015-12-28 07:54:32.774722105 +0100
-+++ src/slicer/poly.cpp 2015-12-28 07:54:41.188055896 +0100
-@@ -225,7 +225,7 @@
- // Start with first vertex as closest
- uint nindex = 0;
- mindist = (vertices[0]-p).squared_length();
-- if (isnan(mindist)) { // for infinity point p return point 0 and distance 0
-+ if (std::isnan(mindist)) { // for infinity point p return point 0 and distance 0
- mindist = 0.;
- return 0;
- }
---- src/slicer/printlines.cpp.orig 2015-12-28 07:54:05.814720635 +0100
-+++ src/slicer/printlines.cpp 2015-12-28 07:54:19.821388065 +0100
-@@ -240,7 +240,7 @@
- if (abs(absolute_extrusion) < 0.00001)
- travel_speed = max(minspeed, speed); // in case speed is too low
-
-- if (!isnan(absolute_extrusion))
-+ if (!std::isnan(absolute_extrusion))
- // allowed to push/pull at arbitrary speed
- extrudedMaterial += absolute_extrusion;
- else
-@@ -335,7 +335,7 @@
- else
- factor = 1./newlines.size();
- newlines[i].absolute_extrusion *= factor;
-- assert(!isnan(newlines[i].absolute_extrusion));
-+ assert(!std::isnan(newlines[i].absolute_extrusion));
-
- }
- return newlines;
diff --git a/sci-misc/repsnapper/metadata.xml b/sci-misc/repsnapper/metadata.xml
deleted file mode 100644
index 8d7cc1dec49e..000000000000
--- a/sci-misc/repsnapper/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">timschmidt/repsnapper</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-misc/repsnapper/repsnapper-2.3.2a_p3.ebuild b/sci-misc/repsnapper/repsnapper-2.3.2a_p3.ebuild
deleted file mode 100644
index 4f043bd5b3b7..000000000000
--- a/sci-misc/repsnapper/repsnapper-2.3.2a_p3.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools versionator
-
-MY_PV="$(get_version_component_range 1-4)$(get_version_component_range 5)"
-MY_PV=${MY_PV/p/}
-
-DESCRIPTION="Host software for controlling the RepRap open source 3D printer"
-HOMEPAGE="https://github.com/timschmidt/repsnapper"
-SRC_URI="https://github.com/timschmidt/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- >=dev-cpp/gtkglextmm-1.2
- dev-cpp/gtkmm:2.4
- dev-cpp/libxmlpp
- dev-libs/libzip
- virtual/opengl
-"
-RDEPEND=${DEPEND}
-
-src_prepare() {
- eautoreconf
-}
diff --git a/sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild b/sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild
deleted file mode 100644
index 26bbc8eb54b9..000000000000
--- a/sci-misc/repsnapper/repsnapper-2.4a_p0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools flag-o-matic versionator
-
-MY_PV="$(get_version_component_range 1-3)$(get_version_component_range 4)"
-MY_PV=${MY_PV/p/}
-
-DESCRIPTION="Host software for controlling the RepRap open source 3D printer"
-HOMEPAGE="https://github.com/timschmidt/repsnapper"
-SRC_URI="https://github.com/timschmidt/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- >=dev-cpp/gtkglextmm-1.2
- dev-cpp/gtkmm:2.4
- dev-cpp/libxmlpp:2.6
- dev-libs/libzip
- virtual/opengl
-"
-RDEPEND=${DEPEND}
-
-src_prepare() {
- epatch "${FILESDIR}/std-c11.patch"
- epatch "${FILESDIR}/${P}-gcc6.patch"
- eautoreconf
- append-cxxflags -std=c++11
-}
diff --git a/sci-misc/repsnapper/repsnapper-2.4a_p3.ebuild b/sci-misc/repsnapper/repsnapper-2.4a_p3.ebuild
deleted file mode 100644
index 860571030c58..000000000000
--- a/sci-misc/repsnapper/repsnapper-2.4a_p3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools flag-o-matic versionator
-
-MY_PV="$(get_version_component_range 1-3)$(get_version_component_range 4)"
-MY_PV=${MY_PV/p/}
-
-DESCRIPTION="Host software for controlling the RepRap open source 3D printer"
-HOMEPAGE="https://github.com/timschmidt/repsnapper"
-SRC_URI="https://github.com/timschmidt/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- >=dev-cpp/gtkglextmm-1.2
- dev-cpp/gtkmm:2.4
- dev-cpp/libxmlpp:2.6
- dev-libs/libzip
- virtual/opengl
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- eautoreconf
- append-cxxflags -std=c++11
-}
diff --git a/sci-misc/repsnapper/repsnapper-9999.ebuild b/sci-misc/repsnapper/repsnapper-9999.ebuild
deleted file mode 100644
index e52ec41c78d7..000000000000
--- a/sci-misc/repsnapper/repsnapper-9999.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools git-r3
-
-DESCRIPTION="Host software for controlling the RepRap open source 3D printer"
-HOMEPAGE="https://github.com/timschmidt/repsnapper"
-EGIT_REPO_URI="https://github.com/timschmidt/${PN}.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="
- >=dev-cpp/gtkglextmm-1.2
- dev-cpp/gtkmm:2.4
- dev-cpp/libxmlpp:2.6
- dev-libs/libzip
- virtual/opengl
-"
-RDEPEND=${DEPEND}
-
-src_prepare() {
- eautoreconf
- append-cxxflags -std=c++11
-}