summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-01-29 08:19:00 -0600
committerBen Kohler <bkohler@gentoo.org>2020-01-29 08:19:53 -0600
commita28ecf7280fdf5c09509c3af2c8b467131f0d209 (patch)
tree66a9498f92fcb9b2d72f0a5460153e3e20cfcbdf
parentsci-misc/netlogo-bin: fix minor QA issues (diff)
downloadgentoo-a28ecf7280fdf5c09509c3af2c8b467131f0d209.tar.gz
gentoo-a28ecf7280fdf5c09509c3af2c8b467131f0d209.tar.bz2
gentoo-a28ecf7280fdf5c09509c3af2c8b467131f0d209.zip
app-emulation/qemu-init-scripts: revbump for EAPI & misc QA fixes
Closes: https://bugs.gentoo.org/622276 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--app-emulation/qemu-init-scripts/files/openrc-run.patch10
-rw-r--r--app-emulation/qemu-init-scripts/qemu-init-scripts-0.3.0-r1.ebuild35
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/qemu-init-scripts/files/openrc-run.patch b/app-emulation/qemu-init-scripts/files/openrc-run.patch
new file mode 100644
index 000000000000..5592ff2e1151
--- /dev/null
+++ b/app-emulation/qemu-init-scripts/files/openrc-run.patch
@@ -0,0 +1,10 @@
+diff --git a/qemu-init-script b/qemu-init-script
+index 937ddfe..b2c060f 100755
+--- a/qemu-init-script
++++ b/qemu-init-script
+@@ -1,4 +1,4 @@
+-#!/sbin/runscript
++#!/sbin/openrc-run
+ # Copyright 2009-2013 Gentoo Foundation
+ # Distributed under the terms of the GNU General Public License v2
+
diff --git a/app-emulation/qemu-init-scripts/qemu-init-scripts-0.3.0-r1.ebuild b/app-emulation/qemu-init-scripts/qemu-init-scripts-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..b953a36d13ca
--- /dev/null
+++ b/app-emulation/qemu-init-scripts/qemu-init-scripts-0.3.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Kvm and qemu init scripts"
+HOMEPAGE="https://gitweb.gentoo.org/proj/kvm-tools.git/"
+
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emulation/qemu
+ net-misc/socat"
+
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/openrc-run.patch )
+
+src_install() {
+ newinitd "${S}/"qemu-init-script qemu
+ newconfd "${S}/"qemu-conf.example qemu.conf.example
+ newsbin "${S}/"qtap-manipulate qtap-manipulate
+ dosym qemu /etc/init.d/kvm
+}
+
+pkg_postinst() {
+ elog "For bridging networking systems, you need these run time utilities:"
+ elog " net-misc/bridge-utils"
+ elog " sys-apps/usermode-utilities"
+ elog ""
+ elog "We will be updating these scripts to use"
+ elog "iptables exclusively in the future"
+}