summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-05 11:24:13 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-05 11:24:13 -0500
commita36e6460f1fa1464b82ef2c8673f995bd8d835d2 (patch)
tree4608de2c06ed9c98f786fd0e5ce152d8a4044900
parentnet-analyzer/rrdtool: Version 1.7.1 (diff)
downloadgentoo-a36e6460f1fa1464b82ef2c8673f995bd8d835d2.tar.gz
gentoo-a36e6460f1fa1464b82ef2c8673f995bd8d835d2.tar.bz2
gentoo-a36e6460f1fa1464b82ef2c8673f995bd8d835d2.zip
app-misc/note: EAPI bump, fix deps, general cleanup
Bug 665824 is forcing a dependency review as virtual/mysql is incorrect This package simply will need DBD-mysql While at it, remove the dodir/cp pairs for into{ins,exe}/do{ins,exe} pairs This remains maintainer-needed as no real testing was done Bug: https://bugs.gentoo.org/665824 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--app-misc/note/note-1.3.3-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/note/note-1.3.3-r2.ebuild b/app-misc/note/note-1.3.3-r2.ebuild
new file mode 100644
index 000000000000..fc0e6b7a020b
--- /dev/null
+++ b/app-misc/note/note-1.3.3-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module
+
+DESCRIPTION="A note taking perl program"
+HOMEPAGE="https://www.daemon.de/NOTE"
+SRC_URI="https://www.daemon.de/idisk/Apps/note/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt dbm general mysql text"
+
+DEPEND="dev-perl/TermReadKey
+ dev-perl/Term-ReadLine-Perl
+ virtual/perl-Storable
+ dev-perl/Config-General
+ crypt? ( dev-perl/Crypt-CBC
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-DES )
+ mysql? ( dev-perl/DBD-mysql )"
+RDEPEND="${DEPEND}"
+
+# extraneous README that gets installed into the perl module
+PERL_RM_FILES=( NOTEDB/README )
+
+src_prepare() {
+ # Supressing file not needed
+ local v
+ for v in mysql text dbm general; do
+ if ! use ${v}; then
+ PERL_RM_FILES+=( NOTEDB/${v}.pm )
+ fi
+ done
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Adding some basic utitily for testing note
+ exeinto /usr/share/${PN}
+ doexe bin/stresstest.sh
+
+ # Adding some help for mysql backend driver
+ if use mysql; then
+ insinto /usr/share/${PN}/mysql
+ exeinto /usr/share/${PN}/mysql
+ doins mysql/{README,sql,permissions}
+ doexe mysql/install.sh
+ fi
+
+ # Adding a sample configuration file
+ insinto /etc
+ doins config/noterc
+
+ dodoc UPGRADE VERSION
+}