summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-06-02 19:10:46 -0400
committerTim Harder <radhermit@gentoo.org>2017-06-02 19:11:28 -0400
commita3c1e85a39bf1207464048d4098c7307a6bc49a6 (patch)
tree9afc41e6028968d2aa70db4485d937342e817d07
parentwww-apps/owncloud: drop unsupported 8.2 (diff)
downloadgentoo-a3c1e85a39bf1207464048d4098c7307a6bc49a6.tar.gz
gentoo-a3c1e85a39bf1207464048d4098c7307a6bc49a6.tar.bz2
gentoo-a3c1e85a39bf1207464048d4098c7307a6bc49a6.zip
dev-libs/npth: version bump to 1.5
-rw-r--r--dev-libs/npth/Manifest1
-rw-r--r--dev-libs/npth/npth-1.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/npth/Manifest b/dev-libs/npth/Manifest
index c2dc53d4dc45..2b0153411824 100644
--- a/dev-libs/npth/Manifest
+++ b/dev-libs/npth/Manifest
@@ -1,2 +1,3 @@
DIST npth-1.3.tar.bz2 295998 SHA256 bca81940436aed0734eb8d0ff8b179e04cc8c087f5625204419f5f45d736a82a SHA512 97b0278cc9448adb42c4a83b8e7bafeed939acaf3dd3a201a1b103df4e48f24224d4bdaeb97903ad1884914ce363cbceffe948a7c1db4f19abf87ca5964f5699 WHIRLPOOL 786dd42c0bb097f47c708cae633f32789d9724cfb5d0e0a12667c754ba32a273ddda6b1c061ad10be1fa2e98dbbcf6850d404e909243fd2e566ba17825f63526
DIST npth-1.4.tar.bz2 299106 SHA256 8915141836a3169a502d65c1ebd785fcc6d406cae5ee84474272ebf2fa96f1f2 SHA512 649009b4fbd2bbbb8fce2911c2f9070a758d037be0d147a63754e3c1f5a9ffb73b907cd09c79314fe60c25084ca7a7b3b387139dd83cc0e11a7e7ba64630ae1f WHIRLPOOL 02642a82d11be58fe5807d178a1fdac0fbcf935e6553d4eebe4d4d24601f04181e6892df0aa532e9b3db198141e6f1b68491bf8c92d18f24686e36492f37f0ab
+DIST npth-1.5.tar.bz2 299308 SHA256 294a690c1f537b92ed829d867bee537e46be93fbd60b16c04630fbbfcd9db3c2 SHA512 20f0ec59d304c68081e42535870af8e76c18e30aa7b04ccdafe60fe5261ad7275c2c0e3ea3a767d6145258a3a39fa641032cd97205318266dd727a5fe7ee331a WHIRLPOOL 1ac5d70aeba45bf66ca7f39b50f01995cca4b19e2d507c116d9704bbc00568d6fce213c469a05253631fe159b14c509dec5597f668669057ea80220b9cf92ca7
diff --git a/dev-libs/npth/npth-1.5.ebuild b/dev-libs/npth/npth-1.5.ebuild
new file mode 100644
index 000000000000..e5f5eb0839ce
--- /dev/null
+++ b/dev-libs/npth/npth-1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool ltprune
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ elibtoolize # for Solaris shared library
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}