summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-06-23 18:51:29 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-06-23 18:51:29 -0400
commita49a79fddb32f1593c239d62d56abad6f451b3b4 (patch)
tree39c68c0e55b381361ad20d300774c950ed028996
parentmedia-libs/vulkan-loader: Bump to 1.1.77.0 (diff)
downloadgentoo-a49a79fddb32f1593c239d62d56abad6f451b3b4.tar.gz
gentoo-a49a79fddb32f1593c239d62d56abad6f451b3b4.tar.bz2
gentoo-a49a79fddb32f1593c239d62d56abad6f451b3b4.zip
media-libs/vulkan-loader: Drop old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.1.70.0.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.1.70.0.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.1.70.0.ebuild
deleted file mode 100644
index 4bed360605f5..000000000000
--- a/media-libs/vulkan-loader/vulkan-loader-1.1.70.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="demos layers wayland X"
-REQUIRED_USE="demos? ( X )"
-
-RDEPEND=""
-DEPEND="${PYTHON_DEPS}
- demos? ( dev-util/glslang:=[${MULTILIB_USEDEP}] )
- layers? (
- dev-util/glslang:=[${MULTILIB_USEDEP}]
- >=dev-util/spirv-tools-2018.2-r1:=[${MULTILIB_USEDEP}]
- )
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? (
- x11-libs/libX11:=[${MULTILIB_USEDEP}]
- x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${P}-Dont-require-glslang-if-not-building-layers.patch"
- "${FILESDIR}/${PN}-Use-a-file-to-get-the-spirv-tools-commit-ID.patch"
- )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_TESTS=False
- -DBUILD_LAYERS=$(usex layers)
- -DBUILD_DEMOS=$(usex demos)
- -DBUILD_VKJSON=False
- -DBUILD_LOADER=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- )
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- keepdir /etc/vulkan/icd.d
-
- cmake-utils_src_install
-}