summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 15:11:20 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 15:36:23 +0200
commita4f190aee43d15b8a3a8a7bc9bd8097685fbf67f (patch)
treeb0677f05f9210d657bb02a9f28ac9da103312966
parentdev-python/pycares: Bump to 2.4.0, py3.7 (diff)
downloadgentoo-a4f190aee43d15b8a3a8a7bc9bd8097685fbf67f.tar.gz
gentoo-a4f190aee43d15b8a3a8a7bc9bd8097685fbf67f.tar.bz2
gentoo-a4f190aee43d15b8a3a8a7bc9bd8097685fbf67f.zip
dev-python/pycares: Bump to 3.0.0_p20190709
The 3.0.0 release has been rewritten to use cffi, and not to support Python 2.7. However, the release itself was buggy, so take a snapshot with the fix. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-3.0.0_p20190709.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index a466b62c08a4..7f4896def1f4 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1,3 +1,4 @@
+DIST pycares-0c831407bc32c6e78a80c5b3d7865ba4c7ac26df.tar.gz 215641 BLAKE2B 36aed2a16138dae5ba05a22418509cbc8cfbf7878d0f27aa2c71110407c5aaaf48445d29ceaa4c4f041f01bb4f4b408c81b2cf5c9f7ba4470dbf4317457f93a0 SHA512 0ef0edd124eef7f897e0bf8b09ffccefaed5ea9eab149cb11c2874087acfb14f15efa6ff6b3967f285b8910adce4b8c228bc69b8ed54c8a6392d3435fc57875b
DIST pycares-2.1.1.tar.gz 226787 BLAKE2B 26716906e78a3fa16bcbd143f63e633ffe4664706b2230f698ea933c15d057f92a0fedc45927743690e9ef8f84191e40f4215878ff2845fd1fb4bcf91f49b765 SHA512 c3524a49f5abe4222c9371ca269918eecf30a77bd52258187766833b4663be861678ebe6f1cb2f50e824d36e75938162d5528abd5445c477f23fb85c24572403
DIST pycares-2.3.0.tar.gz 224941 BLAKE2B 9ab59f8f7294930b5ff97c7340c3f64cd039c4b291b7b33d00da85168638cdfc75552508a72afd91db28c4c1b823a018b45c346a3daf8da15d5160fd691b6c4a SHA512 dc707ab0320e03fb20e728e2e2e52e92ed3388afcf19e4553bc2a15c33a129abee39a9bc423edb7be7113d42989286ab8e8ad48699cc7433a6d8823460fd4678
DIST pycares-2.4.0.tar.gz 214021 BLAKE2B 481d46e9a5726d953d0dcb391a549ba4177e5ac1758a0ecb25bf634b9eb6baa2fbb0544874a78ae46e30a1dd4be8a981f5ebdf1b36cb9aa2e42370074731319e SHA512 7770a2b1fd69bb800019a292e5c9fc1f737b044fb4ca5166ead197da3515f2edac55f947a68f3505c9b404745529287114667d742162c98f2ff84b2c330ef295
diff --git a/dev-python/pycares/pycares-3.0.0_p20190709.ebuild b/dev-python/pycares/pycares-3.0.0_p20190709.ebuild
new file mode 100644
index 000000000000..affb04d0f0ed
--- /dev/null
+++ b/dev-python/pycares/pycares-3.0.0_p20190709.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+EGIT_COMMIT=0c831407bc32c6e78a80c5b3d7865ba4c7ac26df
+MY_P=${PN}-${EGIT_COMMIT}
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="https://github.com/saghul/pycares/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+#RESTRICT="test"
+
+# uses bundled/patched c-ares
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}