summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 12:02:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 13:11:20 +0100
commita5158f5deff99f65e872ce7a915f87a618b19341 (patch)
treef0bb9a380696401dff34db3dbf49755419d63d7b
parentmedia-gfx/symboleditor: Drop 2.0.0 (diff)
downloadgentoo-a5158f5deff99f65e872ce7a915f87a618b19341.tar.gz
gentoo-a5158f5deff99f65e872ce7a915f87a618b19341.tar.bz2
gentoo-a5158f5deff99f65e872ce7a915f87a618b19341.zip
media-sound/soundkonverter: Fix add dirs to Replay Gain tool, EAPI-7
Fix HOMEPAGE. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/soundkonverter/files/soundkonverter-3.0.1-fix-add-dirs.patch23
-rw-r--r--media-sound/soundkonverter/files/soundkonverter-3.0.1-metainfodir.patch23
-rw-r--r--media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild60
3 files changed, 106 insertions, 0 deletions
diff --git a/media-sound/soundkonverter/files/soundkonverter-3.0.1-fix-add-dirs.patch b/media-sound/soundkonverter/files/soundkonverter-3.0.1-fix-add-dirs.patch
new file mode 100644
index 000000000000..cc5a584b5e0c
--- /dev/null
+++ b/media-sound/soundkonverter/files/soundkonverter-3.0.1-fix-add-dirs.patch
@@ -0,0 +1,23 @@
+From 16fb09fcbd5712b7b75004229dbb74f85f213b53 Mon Sep 17 00:00:00 2001
+From: Daniel Faust <hessijames@gmail.com>
+Date: Mon, 6 Aug 2018 18:35:15 +0200
+Subject: [PATCH] Fix adding directories to the Replay Gain tool
+
+Fixes #70
+---
+ replaygainscanner/replaygainfilelist.cpp | 2 +-
+ 1 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/replaygainscanner/replaygainfilelist.cpp b/replaygainscanner/replaygainfilelist.cpp
+index edd64d0..3df5d58 100644
+--- a/replaygainscanner/replaygainfilelist.cpp
++++ b/replaygainscanner/replaygainfilelist.cpp
+@@ -355,7 +355,7 @@ int ReplayGainFileList::listDir( const QString& directory, const QStringList& fi
+ if( filter.contains(codecName) )
+ {
+ QList<QUrl> urls;
+- urls.append(directory + "/" + fileName);
++ urls.append("file://" + directory + "/" + fileName);
+ addFiles( urls, codecName );
+ }
+
diff --git a/media-sound/soundkonverter/files/soundkonverter-3.0.1-metainfodir.patch b/media-sound/soundkonverter/files/soundkonverter-3.0.1-metainfodir.patch
new file mode 100644
index 000000000000..cae51b5790bc
--- /dev/null
+++ b/media-sound/soundkonverter/files/soundkonverter-3.0.1-metainfodir.patch
@@ -0,0 +1,23 @@
+From 8589c87095466f0785902dea6367192bcd813eb3 Mon Sep 17 00:00:00 2001
+From: eclipseo <30413512+eclipseo@users.noreply.github.com>
+Date: Fri, 7 Sep 2018 18:15:43 +0200
+Subject: [PATCH] Install appdata in /usr/share/metainfo
+
+appdata file should now be installed in /usr/share/metainfo. /usr/share/appdata is deprecated.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a0e36de..521d0da 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -135,7 +135,7 @@ install(FILES soundkonverter_replaygainplugin.desktop DESTINATION ${SERVICETYPES
+ install(FILES soundkonverter_ripperplugin.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR})
+ install(FILES soundkonverter-rip-audiocd.desktop DESTINATION ${DATA_INSTALL_DIR}/solid/actions)
+
+-install(FILES soundkonverter.appdata.xml DESTINATION ${SHARE_INSTALL_PREFIX}/appdata)
++install(FILES soundkonverter.appdata.xml DESTINATION ${SHARE_INSTALL_PREFIX}/metainfo)
+
+ add_subdirectory(icons)
+ add_subdirectory(images)
diff --git a/media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild b/media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..b930b9c11d26
--- /dev/null
+++ b/media-sound/soundkonverter/soundkonverter-3.0.1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Frontend to various audio converters"
+HOMEPAGE="https://www.linux-apps.com/p/1126634/ https://github.com/dfaust/soundkonverter"
+SRC_URI="https://github.com/dfaust/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_kdeapps_dep libkcddb)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ >=media-libs/taglib-1.10
+ media-sound/cdparanoia
+"
+RDEPEND="${DEPEND}
+ !media-sound/soundkonverter:4
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-deps.patch"
+ "${FILESDIR}/${P}-fix-add-dirs.patch"
+ "${FILESDIR}/${P}-metainfodir.patch"
+)
+
+S="${WORKDIR}"/${P}/src
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog "soundKonverter optionally supports many different audio formats."
+ elog "You will need to install the appropriate encoding packages for the"
+ elog "formats you require. For a full listing, consult the README file"
+ elog "in /usr/share/doc/${PF}"
+}