summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-20 08:57:57 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-20 09:34:44 +0200
commita5aa3bedbdb5bc10fde05d5fe714c9362aaa585b (patch)
treeec1d847833b9cbd230efdd90feda5f2d93eecf43
parentdev-libs/libmowgli: Fix QA issues (diff)
downloadgentoo-a5aa3bedbdb5bc10fde05d5fe714c9362aaa585b.tar.gz
gentoo-a5aa3bedbdb5bc10fde05d5fe714c9362aaa585b.tar.bz2
gentoo-a5aa3bedbdb5bc10fde05d5fe714c9362aaa585b.zip
net-analyzer/wireshark: [QA] Silence PYTHON_DEPS warning in old ver
Move PYTHON_DEPS to RDEPEND to match eclass used in 3.0*. This is going to silence the CI report, finally making it possible to turn it into proper warning, and the proper fix will land in its time via 3.1.0. Closes: https://bugs.gentoo.org/691464 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-analyzer/wireshark/wireshark-3.0.3.ebuild2
-rw-r--r--net-analyzer/wireshark/wireshark-3.0.4.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.0.3.ebuild b/net-analyzer/wireshark/wireshark-3.0.3.ebuild
index 60215045343..25bf89b8cfe 100644
--- a/net-analyzer/wireshark/wireshark-3.0.3.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.0.3.ebuild
@@ -53,12 +53,12 @@ CDEPEND="
sshdump? ( >=net-libs/libssh-0.6 )
ssl? ( net-libs/gnutls:= )
zlib? ( sys-libs/zlib )
+ ${PYTHON_DEPS}
"
# We need perl for `pod2html`. The rest of the perl stuff is to block older
# and broken installs. #455122
DEPEND="
${CDEPEND}
- ${PYTHON_DEPS}
"
BDEPEND="
!<perl-core/Pod-Simple-3.170
diff --git a/net-analyzer/wireshark/wireshark-3.0.4.ebuild b/net-analyzer/wireshark/wireshark-3.0.4.ebuild
index 421c84a538e..a2a6a43079c 100644
--- a/net-analyzer/wireshark/wireshark-3.0.4.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.0.4.ebuild
@@ -53,12 +53,12 @@ CDEPEND="
sshdump? ( >=net-libs/libssh-0.6 )
ssl? ( net-libs/gnutls:= )
zlib? ( sys-libs/zlib )
+ ${PYTHON_DEPS}
"
# We need perl for `pod2html`. The rest of the perl stuff is to block older
# and broken installs. #455122
DEPEND="
${CDEPEND}
- ${PYTHON_DEPS}
"
BDEPEND="
!<perl-core/Pod-Simple-3.170