summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlramage94 <ramage.lucas@openmailbox.org>2018-04-04 15:03:08 -0400
committerMichał Górny <mgorny@gentoo.org>2018-04-13 20:00:48 +0200
commita617926bcac2c78a0909657c295763d14692676e (patch)
tree354724d70204a66b36dcb9d48740cbf71f837003
parentdev-python/paho-mqtt: add myself to maintainers via proxy-maint (diff)
downloadgentoo-a617926bcac2c78a0909657c295763d14692676e.tar.gz
gentoo-a617926bcac2c78a0909657c295763d14692676e.tar.bz2
gentoo-a617926bcac2c78a0909657c295763d14692676e.zip
dev-python/paho-mqtt: bump version to 1.3.1
Closes: https://github.com/gentoo/gentoo/pull/7137 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/paho-mqtt/Manifest1
-rw-r--r--dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch29
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild35
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
index b253c3a00e25..a5c201165cb1 100644
--- a/dev-python/paho-mqtt/Manifest
+++ b/dev-python/paho-mqtt/Manifest
@@ -1,2 +1,3 @@
DIST paho-mqtt-1.1.zip 159529 BLAKE2B ca3a39628c9cab8c4f3606587a5c853e79535b37a92991ecc32903967952cc00f6a9b967af0d343c4619f3e46ace1330baebc7c2e9dc231673f51775e4e1de25 SHA512 ef6d1a29480671413dbb655bd8f668b99f8587c14589d2180a37142b368e0ce058f8ed967dbfaa82f239c86e295338bc35c9f28a3ea39d21a6034cd8787a63ce
DIST paho-mqtt-1.2.3.tar.gz 91467 BLAKE2B d2f02d6a71498107d8f7c3ef95a9b15d011e16848aa6227c3d7301e4bc474857ea3824a5d1be80bfe0a0c919746e509eaf39ff755925a833ff27f7be24067f99 SHA512 3fb15dc856cbae8885a8a379cea8ceb583ef44954cb8743602fae3e9274d4d0222a87409f048f153180be930bb6e570329768297287a2f8e8c812af03a2c012e
+DIST paho-mqtt-1.3.1.tar.gz 102133 BLAKE2B 905a51824d487cb125e06114bcba6b1ba862de4ab816db16aadb6ff761145fd4724dc6523a0c6837b8a16ced6730c5558612deb138bd95721f15054f5d6851a4 SHA512 95adeeaffbbd4b39d19fbd46feb39ec4a2ac923addd3c754a474b7a91d620bfca1678645c1a09c925e38a33995575944b873e3b2300d7bc2f3c5be3005c74d4c
diff --git a/dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch b/dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch
new file mode 100644
index 000000000000..0cb9750a6f54
--- /dev/null
+++ b/dev-python/paho-mqtt/files/paho-mqtt-1.3.1-strip-test-dependency.patch
@@ -0,0 +1,29 @@
+# Remove Pylama from test dependencies.
+
+diff --git a/setup.cfg b/setup.cfg
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,9 +1,6 @@
+ [aliases]
+ test=pytest
+ [tool:pytest]
+-addopts=-r xs --pylama
++addopts=-r xs
+ strict=True
+ testpaths=tests src
+-[pylama]
+-linters=pyflakes
+-skip=tests/*
+
+diff --git a/setup.py b/setup.py
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@ with open('README.rst', 'rb') as readme_file:
+ readme = readme_file.read().decode('utf-8')
+
+ requirements = []
+-test_requirements = ['pytest', 'pylama']
++test_requirements = ['pytest']
+ needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
+ setup_requirements = ['pytest-runner'] if needs_pytest else []
+
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild
new file mode 100644
index 000000000000..63403cdcae4c
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1"
+HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ ) "
+
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-strip-test-dependency.patch"
+ default
+}
+
+python_test() {
+ esetup.py test
+}