summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-09-23 12:11:51 -0400
committerRick Farina <zerochaos@gentoo.org>2019-09-23 12:20:00 -0400
commita6792f90710bceabe300f85694f0ca3545b799b4 (patch)
tree4352f859df1784386e87e0702f16a5b79ef2cf50
parentgames-mods.eclass: Actually add RESTRICT=bindist this time (diff)
downloadgentoo-a6792f90710bceabe300f85694f0ca3545b799b4.tar.gz
gentoo-a6792f90710bceabe300f85694f0ca3545b799b4.tar.bz2
gentoo-a6792f90710bceabe300f85694f0ca3545b799b4.zip
net-wireless/hackrf-tools: install easy flash for live
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-wireless/hackrf-tools/hackrf-tools-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild b/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
index 667c6b35b871..57c399314261 100644
--- a/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
+++ b/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -30,6 +30,7 @@ RDEPEND="${DEPEND}"
src_install() {
cmake-utils_src_install
+ dosbin "${FILESDIR}/hackrf_easy_flash"
if [[ ${PV} != "9999" ]] ; then
insinto /usr/share/hackrf
newins "${WORKDIR}/hackrf-${PV}/firmware-bin/hackrf_jawbreaker_usb.bin" hackrf_jawbreaker_usb-${PV}.bin
@@ -43,5 +44,6 @@ src_install() {
ln -s hackrf_one_usb-${PV}.dfu "${ED}/usr/share/hackrf/hackrf_one_usb.dfu"
else
ewarn "The compiled firmware files are only available in the versioned releases, you are on your own for this."
+ ewarn "A hackrf-firmware ebuild is available in the pentoo overlay, if you feel adventurous."
fi
}