summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-29 13:07:43 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-29 13:13:23 +0200
commita69d2ddf9372db201cd62a6f72ffc56628c04a30 (patch)
tree99176eeb17848825bb122992b5723ce8030e63d5
parentdev-perl/XML-TreePP: Drop old (diff)
downloadgentoo-a69d2ddf9372db201cd62a6f72ffc56628c04a30.tar.gz
gentoo-a69d2ddf9372db201cd62a6f72ffc56628c04a30.tar.bz2
gentoo-a69d2ddf9372db201cd62a6f72ffc56628c04a30.zip
dev-python/cython: Build tests with -fno-strict-overflow
Pass -fno-strict-overflow to work around test failures. Bug: https://github.com/cython/cython/issues/1911
-rw-r--r--dev-python/cython/cython-0.28.2.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/cython/cython-0.28.2.ebuild b/dev-python/cython/cython-0.28.2.ebuild
index 23c25226c41a..eecc7a4ba326 100644
--- a/dev-python/cython/cython-0.28.2.ebuild
+++ b/dev-python/cython/cython-0.28.2.ebuild
@@ -52,6 +52,8 @@ python_compile_all() {
python_test() {
tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
"${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
|| die "Tests fail with ${EPYTHON}"
}