summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-06-06 15:20:53 +0200
committerPacho Ramos <pacho@gentoo.org>2017-06-06 15:21:17 +0200
commita6ecf4874ab2c74f0f1ff55fbe1ee4be4a98f4f3 (patch)
treeedc3590a7af8231d064f8d5a2b5350025d467a77
parentVersion bump (diff)
downloadgentoo-a6ecf4874ab2c74f0f1ff55fbe1ee4be4a98f4f3.tar.gz
gentoo-a6ecf4874ab2c74f0f1ff55fbe1ee4be4a98f4f3.tar.bz2
gentoo-a6ecf4874ab2c74f0f1ff55fbe1ee4be4a98f4f3.zip
x11-plugins/purple-plugin_pack: Disable xmmsremote compilation (#605218)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild b/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
index bd02ae76e2ec..98d37fe3622e 100644
--- a/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
+++ b/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.7.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils python-any-r1
+
+inherit python-any-r1
MY_PN=${PN/_/-}
MY_P=${MY_PN}-${PV}
@@ -17,16 +17,20 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc x86"
IUSE="debug gtk ncurses spell talkfilters"
-RDEPEND="dev-libs/json-glib
+RDEPEND="
+ dev-libs/json-glib
net-im/pidgin[gtk?,ncurses?]
talkfilters? ( app-text/talkfilters )
- spell? ( app-text/gtkspell:2 )"
+ spell? ( app-text/gtkspell:2 )
+"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}"
+ ${PYTHON_DEPS}
+"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_prepare() {
+ default
sed -e '/CFLAGS=/{s| -g3||}' -i configure || die
}
@@ -45,7 +49,7 @@ src_configure() {
eval DISABLED_PLUGINS="\$${PN//[^a-z]/_}_DISABLED_PLUGINS"
# disable known broken plugins
- DISABLED_PLUGINS+=" schedule findip"
+ DISABLED_PLUGINS+=" schedule findip xmmsremote"
use gtk || DISABLED_PLUGINS+=" $(list_plugins_dep pidgin)"
use ncurses || DISABLED_PLUGINS+=" $(list_plugins_dep finch)"
use spell || DISABLED_PLUGINS+=" $(list_plugins_dep gtkspell)"
@@ -62,11 +66,6 @@ src_configure() {
$(use_enable debug)
}
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README VERSION
-}
-
pkg_preinst() {
elog "Note: if you want to disable some plugins in pack, define"
elog "${PN//[^a-z]/_}_DISABLED_PLUGINS with a list of plugins to"