summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-03-09 22:31:54 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-03-09 22:44:51 +1100
commita8a9d3859a9a33fbc5096e2113aec2fb3d69ebce (patch)
treec8f5377f621722b8baf826309fbd2fbdca05c4c2
parentlxqt-base: remove 0.9.0 (diff)
downloadgentoo-a8a9d3859a9a33fbc5096e2113aec2fb3d69ebce.tar.gz
gentoo-a8a9d3859a9a33fbc5096e2113aec2fb3d69ebce.tar.bz2
gentoo-a8a9d3859a9a33fbc5096e2113aec2fb3d69ebce.zip
profiles: mask lxqt-base/liblxqt-mount & lxqt-base/lxqt-config-randr for removal
-rw-r--r--media-gfx/kphotoalbum/kphotoalbum-4.7.1.ebuild55
-rw-r--r--profiles/package.mask5
2 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/kphotoalbum/kphotoalbum-4.7.1.ebuild b/media-gfx/kphotoalbum/kphotoalbum-4.7.1.ebuild
new file mode 100644
index 000000000000..c4aa950e811c
--- /dev/null
+++ b/media-gfx/kphotoalbum/kphotoalbum-4.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="ar ast be bg bs ca ca@valencia cs da de el en_GB eo es et eu fi fr
+ga gl hi hne hr hu is it ja km lt mai mr nb nds nl nn pa pl pt pt_BR ro ru se sk
+sv tr ug uk vi zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE Photo Album is a tool for indexing, searching, and viewing images"
+HOMEPAGE="http://www.kphotoalbum.org/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+
+LICENSE="GPL-2+ FDL-1.2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +exif +face +geolocation +kipi +map +raw"
+
+REQUIRED_USE="map? ( exif )"
+
+COMMON_DEPEND="
+ >=dev-qt/qtsql-4.4:4[sqlite]
+ media-libs/phonon[qt4]
+ virtual/jpeg:0
+ exif? ( >=media-gfx/exiv2-0.17:= )
+ face? ( >=kde-apps/libkface-15.08.3:4 )
+ geolocation? ( $(add_kdeapps_dep marble) )
+ kipi? ( $(add_kdeapps_dep libkipi '' 4.9.58) )
+ map? ( >=kde-apps/libkgeomap-15.08.3:4 )
+ raw? ( $(add_kdeapps_dep libkdcraw '' 4.9.58) )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ media-video/mplayer
+ kipi? ( >=media-plugins/kipi-plugins-4.7.0 )
+"
+
+DOCS=( ChangeLog README )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with exif Exiv2)
+ $(cmake-utils_use_with face Kface)
+ $(cmake-utils_use_with geolocation Marble)
+ $(cmake-utils_use_with kipi)
+ $(cmake-utils_use_with map KGeoMap)
+ $(cmake-utils_use_with raw Kdcraw)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 1b867da18c36..d904f0b972a5 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -31,6 +31,11 @@
#--- END OF EXAMPLES ---
# Michael Palimaka <kensington@gentoo.org> (09 Mar 2016)
+# Deprecated by upstream. No further releases. Unused.
+lxqt-base/liblxqt-mount
+lxqt-base/lxqt-config-randr
+
+# Michael Palimaka <kensington@gentoo.org> (09 Mar 2016)
# Dead upstream. Doesn't work with new Twitter API.
# Masked for removal in 30 days. Bug 575156
net-im/qwit