summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-09-01 10:02:51 -0500
committerMatthew Thode <mthode@mthode.org>2015-09-01 10:02:51 -0500
commita91e794ebfd1d8ad1521b2952436b6d48beb01a8 (patch)
tree543f9c4e2d209928d5658269a9b68919cea0895b
parentdev-python/mock: get x86 support... again... (diff)
downloadgentoo-a91e794ebfd1d8ad1521b2952436b6d48beb01a8.tar.gz
gentoo-a91e794ebfd1d8ad1521b2952436b6d48beb01a8.tar.bz2
gentoo-a91e794ebfd1d8ad1521b2952436b6d48beb01a8.zip
dev-python/oslotest: adding for liberty
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/oslotest/Manifest1
-rw-r--r--dev-python/oslotest/oslotest-1.10.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/oslotest/Manifest b/dev-python/oslotest/Manifest
index 113f0987cb3f..b2ea561b4f8c 100644
--- a/dev-python/oslotest/Manifest
+++ b/dev-python/oslotest/Manifest
@@ -1,3 +1,4 @@
+DIST oslotest-1.10.0.tar.gz 26092 SHA256 da198416f07df43a1b5c9e02bf05b3f1b7057dd81264b2815bbdfcd610f17650 SHA512 34b017b5adc56578b8893b3858b00c7c59bf6d915cc89e3db00c60cb92ae83af88cfee350c9fc14e477d34b3534d3ea1c08254bd0851e7e99f7e19cca2a85f09 WHIRLPOOL 2a17a69bc4f5148b1b386f664b9f3f5d78a1faba36916c418cf1fdc8397963da715530c9203e66ab541d3cce70e89901f264a26d612298b111f75ade116eca8a
DIST oslotest-1.3.0.tar.gz 18084 SHA256 7c29dcf2289b4de8b3a64764ae617626e86bda948746aced80c49452df9e038a SHA512 f2db5ba6eedebc5937cbee94aa18e3b5ea9933d833ceb1e3906a18d7bc2bc9b423c7608ecad4ab4f8e9099a57ace1b610259a8b1dd7e8ad7f1d60a46ba717bcb WHIRLPOOL 2a4bd1e55ef379a0c7fd413a79af35e208ec3ff90b90fcc84bf36bb2e1a17bc3954545d81e32de4adf410872832b763e470dc3c99ce1893cea5dc1339df9d4ae
DIST oslotest-1.5.0.tar.gz 20622 SHA256 df732f8bd4b6b5d6869e4b570624c4a0ee3f906bee9b4cd70e8933b0dcef5586 SHA512 9e4f335d8eaa9b4c22f127b43ae5a96cf036ea0238b557a549a2b3b465e5f06e7b4c58a72e752e6d1be40a9dc6cee6c331bca4635679eb80c0a36d858c195ae4 WHIRLPOOL 552cd5c5e96634d39fd334619807645eb8258879c1048771b64c618bca3497a1c9449b5b51111a86c7b231e9721a4982b6679fbbb22bf08d546fdbe219814498
DIST oslotest-1.5.1.tar.gz 20723 SHA256 8123fb3471d82b141614728e66beecedecdd33c2844d1ef0c14c89b833339981 SHA512 b69770d260060bfec4185a3d1484d304be0e48c4dfa6ab2613eb3a73fd046eb3b0ad90ed061d8c6cca65bd3e76d7fdbe8832a73ea6674e5c9aa92d7a3978322f WHIRLPOOL 777c6c8a93502e795b3c61ddab62d8b3dffdaed62b65f73b6c63180721a00b4a64fef48a631919ef75c3c2b7e42237d71be78548ef62198113e27ffead4c1ef9
diff --git a/dev-python/oslotest/oslotest-1.10.0.ebuild b/dev-python/oslotest/oslotest-1.10.0.ebuild
new file mode 100644
index 000000000000..80c3f4a21109
--- /dev/null
+++ b/dev-python/oslotest/oslotest-1.10.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="http://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/os-client-config-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ else
+ esetup.py build_sphinx -b man
+ fi
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ doman doc/build/man/oslotest.1
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}