summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 16:45:05 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:39 +0100
commita97c8aeefc34871519f677bd929d9cac2b72169a (patch)
treec79ad3aad3496a08854f9bf387c584fcc94c0939
parentmedia-libs/libao: drop no-op USE=static-libs, libtool.eclass-- (diff)
downloadgentoo-a97c8aeefc34871519f677bd929d9cac2b72169a.tar.gz
gentoo-a97c8aeefc34871519f677bd929d9cac2b72169a.tar.bz2
gentoo-a97c8aeefc34871519f677bd929d9cac2b72169a.zip
media-libs/sdl-gfx: drop no-op USE=static-libs
We add --disable-static just to be sure though. We were already unconditionally deleting both .la and .a, so the USE flag did nothing. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.26-r1.ebuild10
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.26-r1.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.26-r1.ebuild
index 69cfd9504e43..d946b6c8fe4a 100644
--- a/media-libs/sdl-gfx/sdl-gfx-2.0.26-r1.ebuild
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.26-r1.ebuild
@@ -2,25 +2,25 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools multilib-minimal
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="Graphics drawing primitives library for SDL"
HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="ZLIB"
SLOT="0/16" # libSDL_gfx.so.16
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc cpu_flags_x86_mmx static-libs"
+IUSE="doc cpu_flags_x86_mmx"
RDEPEND=">=media-libs/libsdl-1.2.15-r4[video,${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog README )
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
sed -i -e 's/-O //' configure.in || die
@@ -31,7 +31,7 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable static-libs static)
+ --disable-static
}
#multilib_src_install() {
@@ -40,9 +40,11 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
+
if use doc ; then
docinto html
dodoc -r Docs/*
fi
+
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
}
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild
index 373fb1ac374f..92ec91ed3eaf 100644
--- a/media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.26.ebuild
@@ -2,25 +2,25 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit autotools multilib-minimal
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="Graphics drawing primitives library for SDL"
HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc cpu_flags_x86_mmx static-libs"
+IUSE="doc cpu_flags_x86_mmx"
RDEPEND=">=media-libs/libsdl-1.2.15-r4[video,${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog README )
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
sed -i -e 's/-O //' configure.in || die
@@ -31,7 +31,7 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable static-libs static)
+ --disable-static
}
#multilib_src_install() {
@@ -40,9 +40,11 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
+
if use doc ; then
docinto html
dodoc -r Docs/*
fi
+
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
}