summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-03 17:48:49 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-03 17:49:14 +0200
commitaa0ef92c870520bff72b4d8539998a99509bf45a (patch)
tree8cba99e5e0fef0907c63df43811f0e10cc617d8a
parentgames-board/ccgo: Fixed build with sys-libs/ncurses[tinfo] (diff)
downloadgentoo-aa0ef92c870520bff72b4d8539998a99509bf45a.tar.gz
gentoo-aa0ef92c870520bff72b4d8539998a99509bf45a.tar.bz2
gentoo-aa0ef92c870520bff72b4d8539998a99509bf45a.zip
dev-libs/wlc: Remove last-rited pkg
Closes: https://bugs.gentoo.org/684828 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/wlc/Manifest2
-rw-r--r--dev-libs/wlc/metadata.xml24
-rw-r--r--dev-libs/wlc/wlc-0.0.10.ebuild66
-rw-r--r--dev-libs/wlc/wlc-0.0.11.ebuild66
-rw-r--r--dev-libs/wlc/wlc-9999.ebuild68
-rw-r--r--profiles/package.mask5
6 files changed, 0 insertions, 231 deletions
diff --git a/dev-libs/wlc/Manifest b/dev-libs/wlc/Manifest
deleted file mode 100644
index 8c1969a839c7..000000000000
--- a/dev-libs/wlc/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST wlc-0.0.10.tar.bz2 249721 BLAKE2B 7d1d1f3bb0b878912b4bcabec3046d45a243b83acedb77b0e939c10c9c08b47ac6a90bd55b0c2e7df8fd8e591aa4be3f848dbe3f6aff67670aa4ac8c716c96ba SHA512 93474b04aad6534d850d9666cb7ba2b588d8beda89d785de1d569951e3c410ec66da84cdaab5e99060e61360b9bdffa96226f20e1d1e906873edc6850c34500c
-DIST wlc-0.0.11.tar.bz2 247642 BLAKE2B 705b60eb96951e64a0f47bd5091cddb4d6bdea9553db02701fec1e3fbe3288834ae8b6bab5e193457b89c8db451497a1ba299ec6e3b283c92e56c69b1078f517 SHA512 29e7d734cee76b9d0d1fabac71bab33a7146fec8557e583be2d0e85413fa77ed938f23f3bc8728f1f0766239d5eb023ace52abb9b78d40ce1edf876185a60ea5
diff --git a/dev-libs/wlc/metadata.xml b/dev-libs/wlc/metadata.xml
deleted file mode 100644
index 4d7e16aaf19f..000000000000
--- a/dev-libs/wlc/metadata.xml
+++ /dev/null
@@ -1,24 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="person">
- <email>hilobakho@gmail.com</email>
- <name>Mykyta Holubakha</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <use>
- <flag name="systemd">Enable support for systemd-logind.</flag>
- <flag name="X">Enable X11 backend.</flag>
- <flag name="xwayland">Enable XWayland application support.</flag>
- </use>
- <upstream>
- <remote-id type="github">Cloudef/wlc</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-libs/wlc/wlc-0.0.10.ebuild b/dev-libs/wlc/wlc-0.0.10.ebuild
deleted file mode 100644
index dfd3d6fd8a5a..000000000000
--- a/dev-libs/wlc/wlc-0.0.10.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A helper library for Wayland compositors"
-HOMEPAGE="https://github.com/Cloudef/wlc"
-
-SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="MIT ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="X static-libs systemd +xwayland"
-
-RDEPEND="virtual/opengl
- virtual/libudev
- media-libs/mesa[wayland,gbm,gles2,egl]
- x11-libs/libdrm
- x11-libs/pixman
- x11-libs/libxkbcommon
- x11-misc/xkeyboard-config
- dev-libs/libinput
- dev-libs/wayland
- X? (
- x11-libs/libX11
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-libs/libXfixes
- )
- xwayland? (
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-base/xorg-server[wayland]
- )
- systemd? ( sys-apps/systemd sys-apps/dbus )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=dev-libs/wayland-protocols-1.7"
-
-src_configure() {
- local mycmakeargs=(
- -DWLC_BUILD_EXAMPLES=OFF
- -DWLC_BUILD_TESTS=OFF
-
- -DWLC_BUILD_STATIC=$(usex static-libs)
-
- -DWLC_X11_BACKEND_SUPPORT=$(usex X)
- -DWLC_XWAYLAND_SUPPORT=$(usex xwayland)
-
- $(cmake-utils_use_find_package systemd Systemd)
- $(cmake-utils_use_find_package systemd Dbus)
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if use X && ! use xwayland; then
- elog "xwayland use flag is required for X11 applications support"
- fi
-}
diff --git a/dev-libs/wlc/wlc-0.0.11.ebuild b/dev-libs/wlc/wlc-0.0.11.ebuild
deleted file mode 100644
index 9786fe291a83..000000000000
--- a/dev-libs/wlc/wlc-0.0.11.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A helper library for Wayland compositors"
-HOMEPAGE="https://github.com/Cloudef/wlc"
-
-SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="MIT ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="X static-libs systemd +xwayland"
-
-RDEPEND="virtual/opengl
- virtual/libudev
- media-libs/mesa[wayland,gbm,gles2,egl]
- x11-libs/libdrm
- x11-libs/pixman
- x11-libs/libxkbcommon
- x11-misc/xkeyboard-config
- dev-libs/libinput
- dev-libs/wayland
- X? (
- x11-libs/libX11
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-libs/libXfixes
- )
- xwayland? (
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-base/xorg-server[wayland]
- )
- systemd? ( sys-apps/systemd sys-apps/dbus )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=dev-libs/wayland-protocols-1.7"
-
-src_configure() {
- local mycmakeargs=(
- -DWLC_BUILD_EXAMPLES=OFF
- -DWLC_BUILD_TESTS=OFF
-
- -DWLC_BUILD_STATIC=$(usex static-libs)
-
- -DWLC_X11_BACKEND_SUPPORT=$(usex X)
- -DWLC_XWAYLAND_SUPPORT=$(usex xwayland)
-
- $(cmake-utils_use_find_package systemd Systemd)
- $(cmake-utils_use_find_package systemd Dbus)
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if use X && ! use xwayland; then
- elog "xwayland use flag is required for X11 applications support"
- fi
-}
diff --git a/dev-libs/wlc/wlc-9999.ebuild b/dev-libs/wlc/wlc-9999.ebuild
deleted file mode 100644
index 709fe5def74d..000000000000
--- a/dev-libs/wlc/wlc-9999.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit git-r3 cmake-utils
-
-DESCRIPTION="A helper library for Wayland compositors"
-HOMEPAGE="https://github.com/Cloudef/wlc"
-
-EGIT_REPO_URI="https://github.com/Cloudef/wlc.git"
-
-LICENSE="MIT ZLIB"
-SLOT="0"
-KEYWORDS=""
-IUSE="X static-libs systemd +xwayland"
-
-RDEPEND="virtual/opengl
- virtual/libudev
- media-libs/mesa[wayland,gbm,gles2,egl]
- x11-libs/libdrm
- x11-libs/pixman
- x11-libs/libxkbcommon
- x11-misc/xkeyboard-config
- dev-libs/libinput
- dev-libs/wayland
- X? (
- x11-libs/libX11
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-libs/libXfixes
- )
- xwayland? (
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-base/xorg-server[wayland]
- )
- systemd? ( sys-apps/systemd sys-apps/dbus )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-libs/wayland-protocols"
-
-src_configure() {
- local mycmakeargs=(
- -DWLC_BUILD_EXAMPLES=OFF
- -DWLC_BUILD_TESTS=OFF
-
- -DWLC_BUILD_STATIC=$(usex static-libs)
-
- -DWLC_X11_BACKEND_SUPPORT=$(usex X)
- -DWLC_XWAYLAND_SUPPORT=$(usex xwayland)
-
- $(cmake-utils_use_find_package systemd Systemd)
- $(cmake-utils_use_find_package systemd Dbus)
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if use X && ! use xwayland
- then
- elog "xwayland use flag is required for X11 applications support"
- fi
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 65855617bd50..1a386b9fa3b1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -292,11 +292,6 @@ dev-python/pytest-relaxed
# it. Removal in 30 days. Bug #581720.
media-tv/tvbrowser
-# Michał Górny <mgorny@gentoo.org> (02 May 2019)
-# Discontinued upstream, and no longer required by any packages
-# in Gentoo. Removal in 30 days. Bug #684828.
-dev-libs/wlc
-
# Jory A. Pratt <anarchy@gentoo.org> (1 May 2019)
# No longer supported and or needed by in tree packages.
# Masked for removal in 30 Days. Bug #684904