summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-04-03 20:49:49 +0200
committerPacho Ramos <pacho@gentoo.org>2020-04-03 20:50:00 +0200
commitaa2fdf6947e9f98d25d726f0e648fd88cb42bdbe (patch)
tree570234060e5890cf5e0d9cfcff43cddbc728f89f
parentdev-db/etcd: 3.4.7 bump (diff)
downloadgentoo-aa2fdf6947e9f98d25d726f0e648fd88cb42bdbe.tar.gz
gentoo-aa2fdf6947e9f98d25d726f0e648fd88cb42bdbe.tar.bz2
gentoo-aa2fdf6947e9f98d25d726f0e648fd88cb42bdbe.zip
net-misc/r8168: Bump to 8.048.02
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--net-misc/r8168/Manifest1
-rw-r--r--net-misc/r8168/files/kernel56.patch50
-rw-r--r--net-misc/r8168/r8168-8.048.02.ebuild36
3 files changed, 87 insertions, 0 deletions
diff --git a/net-misc/r8168/Manifest b/net-misc/r8168/Manifest
index fe7c83a9a60f..f1ac59923725 100644
--- a/net-misc/r8168/Manifest
+++ b/net-misc/r8168/Manifest
@@ -1 +1,2 @@
DIST r8168-8.048.00.tar.bz2 109018 BLAKE2B e3587fda9cdad8a8433933daef7f05b123b661e6079703c840fb20562ff8511424bf183781970957fa3b0371ebcb4c7a5b7ef84101c3ac5bed7d3eee1236194c SHA512 425d3e0fc56006e9371c31078d32f6fd135a038b13ec1c4f1b809f68e73e8fd15e4a4c2d027c0b4a2cee9ef0dda348b478cc855fb123eb05e4157564ab9de12a
+DIST r8168-8.048.02.tar.bz2 109232 BLAKE2B 24c04cd0e47fce427ef7de1a2e41e384fd7c0d8dd028715411cc6f47901b703c824dd9c15bc0ed90f649520bd5fd25dbd48cdc37f94ca8f838a07faa99c8aa84 SHA512 d9d828e4717d2857bd38e8c9b9005de19387419db9bc8d174f5c8a8ea120c81c3094770b164a1f92cec7833696d7a1302332ef473c5852146fff5dbf9a69196e
diff --git a/net-misc/r8168/files/kernel56.patch b/net-misc/r8168/files/kernel56.patch
new file mode 100644
index 000000000000..23bb3a1856aa
--- /dev/null
+++ b/net-misc/r8168/files/kernel56.patch
@@ -0,0 +1,50 @@
+--- r8168-8.048.00/src/r8168_n.c 2019-11-26 08:32:35.000000000 +0000
++++ r8168-8.048.00/src/r8168_n.c 2020-03-16 12:34:04.893511463 +0000
+@@ -456,7 +456,13 @@ static void rtl8168_hw_config(struct net
+ static void rtl8168_hw_start(struct net_device *dev);
+ static int rtl8168_close(struct net_device *dev);
+ static void rtl8168_set_rx_mode(struct net_device *dev);
++
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,6,0)
+ static void rtl8168_tx_timeout(struct net_device *dev);
++#else
++static void rtl8168_tx_timeout(struct net_device *dev, unsigned int txqueue);
++#endif
++
+ static struct net_device_stats *rtl8168_get_stats(struct net_device *dev);
+ static int rtl8168_rx_interrupt(struct net_device *, struct rtl8168_private *, napi_budget);
+ static int rtl8168_change_mtu(struct net_device *dev, int new_mtu);
+@@ -1616,12 +1622,21 @@ static int rtl8168_proc_open(struct inod
+ return single_open(file, show, dev);
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,6,0)
+ static const struct file_operations rtl8168_proc_fops = {
+ .open = rtl8168_proc_open,
+ .read = seq_read,
+ .llseek = seq_lseek,
+ .release = single_release,
+ };
++#else
++static const struct proc_ops rtl8168_proc_fops = {
++ .proc_open = rtl8168_proc_open,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = single_release,
++};
++#endif
+ #endif
+
+ /*
+@@ -27844,7 +27859,11 @@ static void rtl8168_reset_task(struct wo
+ }
+
+ static void
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,6,0)
+ rtl8168_tx_timeout(struct net_device *dev)
++#else
++rtl8168_tx_timeout(struct net_device *dev, unsigned int txqueue)
++#endif
+ {
+ struct rtl8168_private *tp = netdev_priv(dev);
+ unsigned long flags; \ No newline at end of file
diff --git a/net-misc/r8168/r8168-8.048.02.ebuild b/net-misc/r8168/r8168-8.048.02.ebuild
new file mode 100644
index 000000000000..299ab1010e46
--- /dev/null
+++ b/net-misc/r8168/r8168-8.048.02.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+# "GBE Ethernet LINUX driver r8168 for kernel up to 4.15" from above link,
+# we need to mirror it to avoid users from needing to fill a captcha to
+# download
+SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="!R8169"
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+PATCHES=( "${FILESDIR}/kernel56.patch" )
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+}