summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-16 19:14:24 +0000
committerSam James <sam@gentoo.org>2021-05-16 19:34:59 +0000
commitaa389198640ebfa07fb43bcb32403b77de7a815b (patch)
treec0579de7fb0772c5131f1f766c2bc865ac8fc229
parentmail-client/s-nail: add ~ppc64 keyword (diff)
downloadgentoo-aa389198640ebfa07fb43bcb32403b77de7a815b.tar.gz
gentoo-aa389198640ebfa07fb43bcb32403b77de7a815b.tar.bz2
gentoo-aa389198640ebfa07fb43bcb32403b77de7a815b.zip
sys-fabric/libnes: fix broken src_unpack
Closes: https://bugs.gentoo.org/514258 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fabric/libnes/libnes-1.1.4.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-fabric/libnes/libnes-1.1.4.ebuild b/sys-fabric/libnes/libnes-1.1.4.ebuild
index 0b48b23ebcdc..384f843aa14e 100644
--- a/sys-fabric/libnes/libnes-1.1.4.ebuild
+++ b/sys-fabric/libnes/libnes-1.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,6 +19,16 @@ RDEPEND="${DEPEND}
!sys-fabric/openib-userspace"
block_other_ofed_versions
+src_unpack() {
+ default
+
+ # /var/tmp/portage/sys-fabric/libnes-1.1.4/work/OFED-3.12-rc1/SRPMS/libnes-1.1.4-0..src.rpm
+ # bug #514258
+ mv "${WORKDIR}"/OFED-3.12-rc1/SRPMS/libnes-1.1.4-0..src.rpm "${WORKDIR}"/OFED-3.12-rc1/SRPMS/libnes-1.1.4-0.src.rpm || die
+
+ openib_src_unpack
+}
+
src_configure() {
econf $(use_enable static-libs static)
}