summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-07-08 21:33:55 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2017-07-08 21:34:51 +0300
commitab2d3e9ff887c8d228d5be16ea0047f6d296a022 (patch)
tree78ab24f47e525db419903870dd642615ea3a7aee
parentmedia-fonts/unifont: bump to 10.0.4 (diff)
downloadgentoo-ab2d3e9ff887c8d228d5be16ea0047f6d296a022.tar.gz
gentoo-ab2d3e9ff887c8d228d5be16ea0047f6d296a022.tar.bz2
gentoo-ab2d3e9ff887c8d228d5be16ea0047f6d296a022.zip
app-crypt/gpgme: fix gcc-7 issue
Bug: 623622 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-crypt/gpgme/files/gpgme-1.8.0-gcc-7.patch16
-rw-r--r--app-crypt/gpgme/gpgme-1.8.0-r3.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/app-crypt/gpgme/files/gpgme-1.8.0-gcc-7.patch b/app-crypt/gpgme/files/gpgme-1.8.0-gcc-7.patch
new file mode 100644
index 000000000000..9dd3e85cbfb7
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.8.0-gcc-7.patch
@@ -0,0 +1,16 @@
+diff --git a/lang/qt/src/qgpgmenewcryptoconfig.cpp b/lang/qt/src/qgpgmenewcryptoconfig.cpp
+index eb3af56..af47594 100644
+--- a/lang/qt/src/qgpgmenewcryptoconfig.cpp
++++ b/lang/qt/src/qgpgmenewcryptoconfig.cpp
+@@ -51,2 +51,3 @@
+ #include <cassert>
++#include <functional> /* std::mem_fn */
+
+diff --git a/lang/qt/src/threadedjobmixin.h b/lang/qt/src/threadedjobmixin.h
+index 32b23db..c4f85c2 100644
+--- a/lang/qt/src/threadedjobmixin.h
++++ b/lang/qt/src/threadedjobmixin.h
+@@ -53,2 +53,3 @@
+ #include <cassert>
++#include <functional> /* std::function */
+
diff --git a/app-crypt/gpgme/gpgme-1.8.0-r3.ebuild b/app-crypt/gpgme/gpgme-1.8.0-r3.ebuild
index 852f90334303..c18cb6e64d68 100644
--- a/app-crypt/gpgme/gpgme-1.8.0-r3.ebuild
+++ b/app-crypt/gpgme/gpgme-1.8.0-r3.ebuild
@@ -39,6 +39,7 @@ REQUIRED_USE="qt5? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
PATCHES=(
"${FILESDIR}"/${PN}-1.1.8-et_EE.patch
"${FILESDIR}"/${P}-cmake.patch
+ "${FILESDIR}"/${P}-gcc-7.patch
)
do_python() {