summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-01 11:46:57 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-01 22:13:59 -0500
commitab585d5fa736afc05a77b6ba51f2ec6e1ea262c1 (patch)
tree2e596acafdb02970781b7003ad28a9f3623272dd
parentapp-eselect/eselect-wine: stabilize 2.0.1 for ALLARCHES (diff)
downloadgentoo-ab585d5fa736afc05a77b6ba51f2ec6e1ea262c1.tar.gz
gentoo-ab585d5fa736afc05a77b6ba51f2ec6e1ea262c1.tar.bz2
gentoo-ab585d5fa736afc05a77b6ba51f2ec6e1ea262c1.zip
app-emulation/wine-gecko: EAPI6->8, set req use, default abi_x86_32
Doing both versions given will be keeping both for a long time. abi_x86_32 default is meant to match wine's default Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild36
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47.3.ebuild34
2 files changed, 33 insertions, 37 deletions
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
index e5a5a8df49a9..19a6f076b27f 100644
--- a/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
+++ b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
@@ -1,37 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
+DESCRIPTION="Mozilla Gecko based version of Internet Explorer for Wine"
HOMEPAGE="https://winehq.org"
SRC_URI="
- !shared? (
- abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.msi )
- )
shared? (
- abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.tar.xz )
- abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.tar.xz )
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86_64.tar.xz )
)
-"
+ !shared? (
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86_64.msi )
+ )"
+S="${WORKDIR}"
LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
SLOT="${PV}"
KEYWORDS="amd64 x86"
-IUSE="abi_x86_32 abi_x86_64 +shared"
-
-DEPEND="!!app-emulation/wine:0"
-
-S="${WORKDIR}"
+IUSE="+abi_x86_32 abi_x86_64 +shared"
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
src_install() {
insinto /usr/share/wine/gecko
+
if use shared; then
- use abi_x86_32 && doins -r "${P}-x86"
- use abi_x86_64 && doins -r "${P}-x86_64"
+ use abi_x86_32 && doins -r ${P}-x86
+ use abi_x86_64 && doins -r ${P}-x86_64
else
- use abi_x86_32 && doins "${DISTDIR}/${PN}-${PV}-x86.msi"
- use abi_x86_64 && doins "${DISTDIR}/${PN}-${PV}-x86_64.msi"
+ use abi_x86_32 && doins "${DISTDIR}"/${P}-x86.msi
+ use abi_x86_64 && doins "${DISTDIR}"/${P}-x86_64.msi
fi
}
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47.3.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47.3.ebuild
index 08acbaed7440..0377ae3bc710 100644
--- a/app-emulation/wine-gecko/wine-gecko-2.47.3.ebuild
+++ b/app-emulation/wine-gecko/wine-gecko-2.47.3.ebuild
@@ -1,37 +1,35 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
+DESCRIPTION="Mozilla Gecko based version of Internet Explorer for Wine"
HOMEPAGE="https://winehq.org"
SRC_URI="
- !shared? (
- abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.msi )
- )
shared? (
- abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.tar.xz )
- abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.tar.xz )
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86_64.tar.xz )
)
-"
+ !shared? (
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86_64.msi )
+ )"
+S="${WORKDIR}"
LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="abi_x86_32 abi_x86_64 +shared"
-
-DEPEND="!!app-emulation/wine:0"
-
-S="${WORKDIR}"
+IUSE="+abi_x86_32 abi_x86_64 +shared"
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
src_install() {
insinto /usr/share/wine/gecko
+
if use shared; then
- use abi_x86_32 && doins -r "${P}-x86"
- use abi_x86_64 && doins -r "${P}-x86_64"
+ use abi_x86_32 && doins -r ${P}-x86
+ use abi_x86_64 && doins -r ${P}-x86_64
else
- use abi_x86_32 && doins "${DISTDIR}/${PN}-${PV}-x86.msi"
- use abi_x86_64 && doins "${DISTDIR}/${PN}-${PV}-x86_64.msi"
+ use abi_x86_32 && doins "${DISTDIR}"/${P}-x86.msi
+ use abi_x86_64 && doins "${DISTDIR}"/${P}-x86_64.msi
fi
}