summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-29 12:32:15 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-29 13:26:19 -0800
commitab83b5423e93976db30c31e680691a95934cde9a (patch)
treee9f6f10121fcfa48c3a865f0185403f114cab7d8
parentx11-libs/libXfixes: dropped ~x64-freebsd ~x86-freebsd ~x86-interix (diff)
downloadgentoo-ab83b5423e93976db30c31e680691a95934cde9a.tar.gz
gentoo-ab83b5423e93976db30c31e680691a95934cde9a.tar.bz2
gentoo-ab83b5423e93976db30c31e680691a95934cde9a.zip
x11-apps/xauth: Add live ebuild.
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
new file mode 100644
index 000000000000..4ec4718e9cea
--- /dev/null
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS=""
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# Tests dependend on dev-util/cmdtest awaiting keywording, bug #511202.
+# test? ( dev-util/cmdtest )
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_src_configure
+}
+
+src_test() {
+ # Address sandbox failure, bug #527574
+ addwrite /proc/self/comm
+ autotools-utils_src_test
+}