summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 13:47:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 14:37:26 +0200
commitac368af5b6fddfa1faf208aa4bd044f3318fbecb (patch)
tree38ed5e883b4d5ce850a4d3750bacc8c340c1fc9d
parentdev-db/pgadmin4: Bump to 4.25 (diff)
downloadgentoo-ac368af5b6fddfa1faf208aa4bd044f3318fbecb.tar.gz
gentoo-ac368af5b6fddfa1faf208aa4bd044f3318fbecb.tar.bz2
gentoo-ac368af5b6fddfa1faf208aa4bd044f3318fbecb.zip
kde-frameworks/frameworkintegration: 5.74.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.74.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index b124f3503ac2..80d5f71b23e4 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.70.0.tar.xz 1753940 BLAKE2B 5da86d4b7fe8a696e217273ff468c668ec1e04c138dd756a0a9280fbd6acb99f9cbd3bbce1790886de50335d036e7a99a83f1ea4ad4103101ecc46878d0e071b SHA512 70a72388315c0ca1625bb279b15a9df1693aed9a6dd470af8744b856e5c7cc458b0ffcc384489889e8c3e753edb03062b41cc688361498e45ac3a26d7be70a34
DIST frameworkintegration-5.73.0.tar.xz 1754424 BLAKE2B 1f704d1f3e10c8eef0244defb8e5bbc007b48a921f1e209d1625c17b39ca491e7b804b6ca2fbba7ff8375b8b4f359683dcd98190b25d275cf4b0e77b2e5088e9 SHA512 23366afa4ac57a9b642f93eac2a4bb31ca18afbc1073688bd9e95e317a9b0f3f7854311948ab962e536eea9d04a07411ac7bf1d5863fe79e7d82819761130cfd
+DIST frameworkintegration-5.74.0.tar.xz 1754176 BLAKE2B f325c8362182c066f7fef108a350e9c9378e084c7955e1395fb44918759dbd7e5f55cae037525b286cf9f6b0c67788a766b62bdf737994378b1978a7ef7dd507 SHA512 4bf533b261c149a10ed4b4607f532b57b989f6e130c417a0398216ddbe1b4b3ab964009aa5c021bdc92960f8c25c7f5c66cf8606ed7956b25adfa401d0f08e68
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.74.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.74.0.ebuild
new file mode 100644
index 000000000000..2aee64430b07
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.74.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.15.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}