summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-16 17:22:20 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-16 17:23:15 +0100
commitac3701fa04eec8b93cc5fad1d2943b1ff0e5b99e (patch)
tree4798ccca4db14165e959311f1f6103e1ca0bcdf1
parentapp-misc/elasticsearch: drop old (diff)
downloadgentoo-ac3701fa04eec8b93cc5fad1d2943b1ff0e5b99e.tar.gz
gentoo-ac3701fa04eec8b93cc5fad1d2943b1ff0e5b99e.tar.bz2
gentoo-ac3701fa04eec8b93cc5fad1d2943b1ff0e5b99e.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.11.15.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 325d6d3719cd..2eb2d664908a 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.10.29.tar.gz 2831813 SHA256 8fe003472048113ed6fcc422cc48cc76a49cfdd12f189b832c40a2cc44e452f9 SHA512 50781f792fa01ad64b6f7b6fc05730dff09b10007ef5c23ee558148affb2a126958bd5ed8d1ac4499ddc48a56a5b9df47f20612ae09f41084e6dbac5fc3f3426 WHIRLPOOL 1393943e90c096feaf0d7902408a965ae4fac961cb6cab1bc3f77a1d75478d91e5a0da5a72a3da71c09c44b05778e5b5481a44bd1494112dfe3ec5af3de5f78d
DIST youtube-dl-2017.11.06.tar.gz 2831531 SHA256 6d0c0226a1e914c94a9a68e8bff5a6498bdf783ffb9513ecf18646139c1e58b6 SHA512 0f7707084f84e7375ae61ffa88979990ba27cf2afb44992d75172415190f5959fe317313b127cbdde33500ed6b0525e9ff03872116dfa7ca188a97e74d562574 WHIRLPOOL a077a96023aec039e74380f91c34c59208cae3e2e06635003547bf8ed7fbb80756bdc73fac7b5607449b9740ea61ce2f1185d2adc738ccd7f6cbfbc32fe9b4ad
+DIST youtube-dl-2017.11.15.tar.gz 2834012 SHA256 88b177baaad0ceafc496bbef790c24b35272cbd9527e2b64f536131aad040ce8 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96 WHIRLPOOL a9d82b0881c91ed410cb57c14a80417e1791a44a51e2a59f14b039ca8bed25715b8de5e70b4434d5b0e87ebbde9b17399e04cf468e878a14b09e3729f239f66f
diff --git a/net-misc/youtube-dl/youtube-dl-2017.11.15.ebuild b/net-misc/youtube-dl/youtube-dl-2017.11.15.ebuild
new file mode 100644
index 000000000000..975ce26c347e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.11.15.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex motherless myvidster
+ porn91 porncom pornflip pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}