summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-23 07:10:52 +0200
committerHans de Graaff <graaff@gentoo.org>2015-10-23 09:04:05 +0200
commitac5d2974e1d6582b4e1788da2484fd0400419023 (patch)
tree0b83a6130e78182b2341ea2396680e1c5bcb40b7
parentsci-geosciences/grass: patch, fixes failure built with format-security (diff)
downloadgentoo-ac5d2974e1d6582b4e1788da2484fd0400419023.tar.gz
gentoo-ac5d2974e1d6582b4e1788da2484fd0400419023.tar.bz2
gentoo-ac5d2974e1d6582b4e1788da2484fd0400419023.zip
dev-ruby/fast_gettext: add 1.0.0
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-ruby/fast_gettext/Manifest1
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-1.0.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/fast_gettext/Manifest b/dev-ruby/fast_gettext/Manifest
index 504347510d96..4eed8e33478b 100644
--- a/dev-ruby/fast_gettext/Manifest
+++ b/dev-ruby/fast_gettext/Manifest
@@ -1,2 +1,3 @@
DIST fast_gettext-0.9.0.tar.gz 86616 SHA256 773f1112524f1777f4f46ce80c5e1341dd270d232d86808d5ecc27d5b4d83e29 SHA512 901e9725ae537300be078febf4c5c94f466da48b0e4d3611037bfc98b914436a23828708177d6874c7b2ae60245631cd414ee52bd1b9de90c6ff8d1a6dbe37a4 WHIRLPOOL 06f858d501d66cfc609ff2a75010e73b33f706d388286a64ce923a6a87f96ddcc98a6623644b8bac9e57dbe86b7345ddd7aaf601d69ca600e6f8a7c9c8e95114
DIST fast_gettext-0.9.2.tar.gz 86892 SHA256 7c7de3f9ac19d2e5a81fa15bf0dcd4d54bcb92051e881d83265c6cdadfce239b SHA512 d8bfe755ba6754ff474a6d0e42e9a725aa00f20b381fe5c0a2a2dc3efc5e0bf6096450e0665cd4369717296dc55cd316f836d9cd35b96764eb56e3ca33379c14 WHIRLPOOL 615f5357815d8321d1f099889b352826034af1defbf8a6a4383b9e71b7e37ed06c582e0e957ec4e9a2345b3b84dce9a5432e3d85946f679fa27fcafe04cbce4c
+DIST fast_gettext-1.0.0.tar.gz 86573 SHA256 8390793a29d291b4efbad01e4c579fcb86200b91e87a72d667fb5e1d451b53a2 SHA512 f9c1656218fbb8f514e10bac6b2656a39013dc0b745e0741cea727280aa0153f3555badc4cbd18fea6bff27e3542c62bb4a7808b0565d6282aa4444ee154cb8e WHIRLPOOL 0d1d1bca6a87364a5a834ca88a1906ef90fbd353890191cd0865103865be396dd7c9ce5c9f8abbbfaa088178ee1a7eecfd57b8a16291214f767b775f7737c81a
diff --git a/dev-ruby/fast_gettext/fast_gettext-1.0.0.ebuild b/dev-ruby/fast_gettext/fast_gettext-1.0.0.ebuild
new file mode 100644
index 000000000000..ef29405f1ba9
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-1.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/protected_attributes dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}