summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-24 18:59:40 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-24 19:00:27 +0100
commitad80f329e6e91c1c6549c8df3c298a4d1d8a6657 (patch)
treebe2224fcb9eae4574825a5d7438cfa8de2bc6dce
parentsci-biology/allpathslg: Fix building with GCC 7 (diff)
downloadgentoo-ad80f329e6e91c1c6549c8df3c298a4d1d8a6657.tar.gz
gentoo-ad80f329e6e91c1c6549c8df3c298a4d1d8a6657.tar.bz2
gentoo-ad80f329e6e91c1c6549c8df3c298a4d1d8a6657.zip
sci-biology/allpathslg: Sanitize ebuild
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sci-biology/allpathslg/allpathslg-52488-r2.ebuild19
1 files changed, 2 insertions, 17 deletions
diff --git a/sci-biology/allpathslg/allpathslg-52488-r2.ebuild b/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
index 391575f4f057..964904d66551 100644
--- a/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
+++ b/sci-biology/allpathslg/allpathslg-52488-r2.ebuild
@@ -29,26 +29,11 @@ PATCHES=(
)
pkg_pretend() {
- # as of release 44849, GCC 4.7.0 (or higher) is required
- # seems pre gcc-4.7 users must stay with:
- # ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/2013/2013-01/allpathslg-44837.tar.gz
- if [[ ${MERGE_TYPE} != binary ]]; then
- tc-is-gcc && [[ $(gcc-version) < 4.7 ]] && \
- die "You need to use gcc >4.7"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
pkg_setup() {
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
src_prepare() {