summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-06 13:31:30 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-06 13:31:30 -0400
commitae67dc262a42bbbfe720eff3f552ed257530ed69 (patch)
treeed3cceb0a5ee68a38e3c29357400ab1376a8d1d6
parentdev-python/robotframework: Add python3_6 to PYTHON_COMPAT (diff)
downloadgentoo-ae67dc262a42bbbfe720eff3f552ed257530ed69.tar.gz
gentoo-ae67dc262a42bbbfe720eff3f552ed257530ed69.tar.bz2
gentoo-ae67dc262a42bbbfe720eff3f552ed257530ed69.zip
dev-php/pecl-oauth: Revbump for 7.2 support
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.2-r2.ebuild (renamed from dev-php/pecl-oauth/pecl-oauth-2.0.2-r1.ebuild)14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.2-r1.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.2-r2.ebuild
index 988ba351a82a..987a87b85ee0 100644
--- a/dev-php/pecl-oauth/pecl-oauth-2.0.2-r1.ebuild
+++ b/dev-php/pecl-oauth/pecl-oauth-2.0.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -6,12 +6,12 @@ PHP_EXT_NAME="oauth"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-USE_PHP="php5-6 php7-0 php7-1"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
inherit php-ext-pecl-r3
# Really only build for 7.0
-USE_PHP="php7-0 php7-1"
+USE_PHP="php7-0 php7-1 php7-2"
KEYWORDS="~amd64 ~x86"
@@ -24,11 +24,13 @@ DEPEND="php_targets_php7-0? ( dev-lang/php:7.0[hash]
dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
php_targets_php7-1? ( dev-lang/php:7.1[hash]
dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+ php_targets_php7-2? ( dev-lang/php:7.2[hash]
+ dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
"
RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6(-)?] )"
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
local PATCHES=( "${FILESDIR}/${PV}-compare_segfault.patch" )
php-ext-source-r3_src_prepare
else
@@ -37,7 +39,7 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
local PHP_EXT_ECONF_ARGS=(
--enable-oauth
$(use_with curl)
@@ -48,7 +50,7 @@ src_configure() {
}
src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
php-ext-pecl-r3_src_install
fi
}