summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-13 16:27:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-13 16:32:53 +0100
commitafb7a2ee7121d7b4ef5132acaa423aea0139a4a0 (patch)
tree454b4e47b1d880489d00943d29d5c6ccb4394623
parentmedia-sound/mumble: Added 1.3.0 snapshot. (diff)
downloadgentoo-afb7a2ee7121d7b4ef5132acaa423aea0139a4a0.tar.gz
gentoo-afb7a2ee7121d7b4ef5132acaa423aea0139a4a0.tar.bz2
gentoo-afb7a2ee7121d7b4ef5132acaa423aea0139a4a0.zip
media-sound/murmur: Bumped live ebuild to EAPI-7
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-sound/murmur/murmur-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/media-sound/murmur/murmur-9999.ebuild b/media-sound/murmur/murmur-9999.ebuild
index fa867bd67036..9795d40d3832 100644
--- a/media-sound/murmur/murmur-9999.ebuild
+++ b/media-sound/murmur/murmur-9999.ebuild
@@ -1,19 +1,25 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit qmake-utils systemd user readme.gentoo-r1
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" = 9999 ]] ; then
+if [[ "${PV}" == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
EGIT_SUBMODULES=( '-*' )
else
- MY_P="mumble-${PV/_/~}"
- SRC_URI="https://mumble.info/snapshot/${MY_P}.tar.gz"
+ MY_PN="mumble"
+ if [[ "${PV}" == *_pre* ]] ; then
+ MY_P="${MY_PN}-${PV}"
+ SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz"
+ else
+ MY_P="${MY_PN}-${PV/_/~}"
+ SRC_URI="https://mumble.info/snapshot/${MY_P}.tar.gz"
+ fi
KEYWORDS="~amd64 ~arm ~x86"
S="${WORKDIR}/${MY_P}"
fi
@@ -41,6 +47,8 @@ RDEPEND="
DEPEND="${RDEPEND}
>=dev-libs/boost-1.41.0
+"
+BDEPEND="
virtual/pkgconfig"
DOC_CONTENTS="