summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:23:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:19 +0200
commitafe184021c2b8993431d372c7c03e5bc187b2b1d (patch)
treec71f3bf3cdf95d2b508220ac18e3d9913526ebf1
parentchromium.eclass: Also fix ERROR variables (diff)
downloadgentoo-afe184021c2b8993431d372c7c03e5bc187b2b1d.tar.gz
gentoo-afe184021c2b8993431d372c7c03e5bc187b2b1d.tar.bz2
gentoo-afe184021c2b8993431d372c7c03e5bc187b2b1d.zip
dev-ros/diagnostic_aggregator: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/diagnostic_aggregator/Manifest1
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild27
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild27
-rw-r--r--dev-ros/diagnostic_aggregator/metadata.xml5
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/Manifest b/dev-ros/diagnostic_aggregator/Manifest
new file mode 100644
index 000000000000..b6953773385b
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/Manifest
@@ -0,0 +1 @@
+DIST diagnostics-1.8.8.tar.gz 508404 SHA256 e50eb7d49fd2ce13ce8bccb81cb67c198119d7524b3aada37035c8ab9fe2d3ec SHA512 f0e59442cf4cd277c1ef77e7bceec973a15519c9d81bbde21851592ba52c4c7d55a6358c6a65004490b3e3822a6edc772f20e41992a2b3604d9e64e9fd7124ef WHIRLPOOL 32c8fbdc6591abfd270c1c38aebc5dc8f5d7381e5675f6f50f07be0f433bc5a8b81ac33c438d56e753cb75c6914c8fd4c38d9cc82c720fb04b170b4afef597cb
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild
new file mode 100644
index 000000000000..c01522baab44
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.8.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
new file mode 100644
index 000000000000..c01522baab44
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"
diff --git a/dev-ros/diagnostic_aggregator/metadata.xml b/dev-ros/diagnostic_aggregator/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>