summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 16:32:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 17:12:26 +0100
commitb067fb06704b99f199aac3282a7a09099d133e67 (patch)
treeefaaf0643d66f7eb2f167517004c7f760f36a60a
parentdev-ros/amcl: Remove old (diff)
downloadgentoo-b067fb06704b99f199aac3282a7a09099d133e67.tar.gz
gentoo-b067fb06704b99f199aac3282a7a09099d133e67.tar.bz2
gentoo-b067fb06704b99f199aac3282a7a09099d133e67.zip
dev-ros/amcl: fix build with latest cmake
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/amcl/amcl-1.16.3.ebuild1
-rw-r--r--dev-ros/amcl/files/cmake.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-ros/amcl/amcl-1.16.3.ebuild b/dev-ros/amcl/amcl-1.16.3.ebuild
index 61525256fd54..f83edae6cd3d 100644
--- a/dev-ros/amcl/amcl-1.16.3.ebuild
+++ b/dev-ros/amcl/amcl-1.16.3.ebuild
@@ -31,3 +31,4 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/python_orocos_kdl[${PYTHON_USEDEP}] dev-ros/map_server[${PYTHON_USEDEP}] )
"
+PATCHES=( "${FILESDIR}/cmake.patch" )
diff --git a/dev-ros/amcl/files/cmake.patch b/dev-ros/amcl/files/cmake.patch
new file mode 100644
index 000000000000..4ae817168925
--- /dev/null
+++ b/dev-ros/amcl/files/cmake.patch
@@ -0,0 +1,11 @@
+Index: amcl/CMakeLists.txt
+===================================================================
+--- amcl.orig/CMakeLists.txt
++++ amcl/CMakeLists.txt
+@@ -1,5 +1,6 @@
+ cmake_minimum_required(VERSION 3.1)
+ project(amcl)
++include(CheckSymbolExists)
+
+ if(NOT CMAKE_CXX_STANDARD)
+ set(CMAKE_CXX_STANDARD 11)