summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-14 12:16:29 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:26:28 +0200
commitb0873bd368fbf28c94a128fb6e1795ea2423f63c (patch)
tree06b7ba3d10b54d6e8d2ea804f6b589c346d7bf07
parentdev-python/sphinxcontrib-blockdiag: Enable tests, py3.7 (diff)
downloadgentoo-b0873bd368fbf28c94a128fb6e1795ea2423f63c.tar.gz
gentoo-b0873bd368fbf28c94a128fb6e1795ea2423f63c.tar.bz2
gentoo-b0873bd368fbf28c94a128fb6e1795ea2423f63c.zip
dev-python/aiohttp: Fix tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiohttp/aiohttp-3.4.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/aiohttp/aiohttp-3.4.4.ebuild b/dev-python/aiohttp/aiohttp-3.4.4.ebuild
index 2cd4b9b624ed..ec6ebeb0b474 100644
--- a/dev-python/aiohttp/aiohttp-3.4.4.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.4.4.ebuild
@@ -15,6 +15,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
CDEPEND="
>=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
@@ -57,6 +58,8 @@ python_prepare_all() {
sed -e 's:test_compression_brotli:_\0:' \
-e 's:test_feed_eof_no_err_brotli:_\0:' \
-i tests/test_http_parser.py || die
+ # make pytest warnings non-fatal, to unbreak tests
+ sed -i -e '/filterwarnings/d' setup.cfg || die
distutils-r1_python_prepare_all
}
@@ -66,7 +69,7 @@ python_compile_all() {
}
python_test() {
- esetup.py test
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}
python_install_all() {