summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-02-16 17:57:05 +0800
committerYixun Lan <dlan@gentoo.org>2016-02-16 18:04:16 +0800
commitb0f5aa7239b0d047772f4462e7d4f18ac52e2f6f (patch)
treee352c87e07e15dbe9793a06ce6868476af08c72c
parentsys-kernel/vanilla-sources: Automated version bump to {3.12.54,3.18.27,4.1.18... (diff)
downloadgentoo-b0f5aa7239b0d047772f4462e7d4f18ac52e2f6f.tar.gz
gentoo-b0f5aa7239b0d047772f4462e7d4f18ac52e2f6f.tar.bz2
gentoo-b0f5aa7239b0d047772f4462e7d4f18ac52e2f6f.zip
sys-cluster/ceph: warn user about permission changes
Gentoo-bug: 574792 Package-Manager: portage-2.2.27
-rw-r--r--sys-cluster/ceph/ceph-10.0.0.ebuild12
-rw-r--r--sys-cluster/ceph/ceph-9.2.0.ebuild12
-rw-r--r--sys-cluster/ceph/files/README.gentoo11
3 files changed, 30 insertions, 5 deletions
diff --git a/sys-cluster/ceph/ceph-10.0.0.ebuild b/sys-cluster/ceph/ceph-10.0.0.ebuild
index acb485b4278a..5eb497cee3c3 100644
--- a/sys-cluster/ceph/ceph-10.0.0.ebuild
+++ b/sys-cluster/ceph/ceph-10.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -90,6 +90,8 @@ check-reqs_export_vars() {
export CHECKREQS_DISK_BUILD="1400M"
export CHECKREQS_DISK_USR="450M"
fi
+
+ export CHECKREQS_MEMORY="7G"
}
user_setup() {
@@ -184,3 +186,11 @@ src_install() {
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]] && ! version_is_at_least 9.0 ${REPLACING_VERSIONS}; then
+ ewarn "You've upgraded ceph from old version, please fix the permission issue"
+ ewarn "Please refer section 4) in README.gentoo doc for detail info"
+ ewarn " bzless /usr/share/doc/${P}/README.gentoo.bz2"
+ fi
+}
diff --git a/sys-cluster/ceph/ceph-9.2.0.ebuild b/sys-cluster/ceph/ceph-9.2.0.ebuild
index 434fd90e1a2e..0f82103c41ca 100644
--- a/sys-cluster/ceph/ceph-9.2.0.ebuild
+++ b/sys-cluster/ceph/ceph-9.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -90,6 +90,8 @@ check-reqs_export_vars() {
export CHECKREQS_DISK_BUILD="9G"
export CHECKREQS_DISK_USR="450M"
fi
+
+ export CHECKREQS_MEMORY="7G"
}
user_setup() {
@@ -184,3 +186,11 @@ src_install() {
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]] && ! version_is_at_least 9.0 ${REPLACING_VERSIONS}; then
+ ewarn "You've upgraded ceph from old version, please fix the permission issue"
+ ewarn "Please refer section 4) in README.gentoo doc for detail info"
+ ewarn " bzless /usr/share/doc/${P}/README.gentoo.bz2"
+ fi
+}
diff --git a/sys-cluster/ceph/files/README.gentoo b/sys-cluster/ceph/files/README.gentoo
index c59612081366..6e5f8366136c 100644
--- a/sys-cluster/ceph/files/README.gentoo
+++ b/sys-cluster/ceph/files/README.gentoo
@@ -17,9 +17,14 @@
net-misc/openntpd
net-misc/chrony
-4) Starting from version 9.0.x, Ceph daemons run as ‘ceph’ user instead root.
- In order to fix this, we suggest to stop ceph daemons, and fix ownership
+4) Starting from version 9.0.x, Ceph daemons run as user 'ceph' instead of 'root'.
+ In order to solve this, we recommand to stop ceph daemons, and fix the ownership
- chown -R ceph:ceph /var/lib/ceph
+ # chown -R ceph:ceph /var/lib/ceph
+
+ or
+
+ Add the following line to ceph.conf on all hosts:
+ " setuser match path = /var/lib/ceph/$type/$cluster-$id "
https://ceph.com/releases/v9-2-0-infernalis-released/