summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-08-05 02:54:42 +0800
committerJason Zaman <perfinion@gentoo.org>2016-08-08 01:05:15 +0800
commitb15c3235fb69897dfc046cda035243a8e95a97c0 (patch)
tree85685a71e9aab3a59287714d44cd151bba785d89
parentsys-libs/libsepol: update to eapi6 (diff)
downloadgentoo-b15c3235fb69897dfc046cda035243a8e95a97c0.tar.gz
gentoo-b15c3235fb69897dfc046cda035243a8e95a97c0.tar.bz2
gentoo-b15c3235fb69897dfc046cda035243a8e95a97c0.zip
sys-libs/libselinux: update to eapi6
Package-Manager: portage-2.2.28
-rw-r--r--sys-libs/libselinux/libselinux-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/libselinux/libselinux-9999.ebuild b/sys-libs/libselinux/libselinux-9999.ebuild
index 8539807bebde..d929bbda1458 100644
--- a/sys-libs/libselinux/libselinux-9999.ebuild
+++ b/sys-libs/libselinux/libselinux-9999.ebuild
@@ -2,12 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
USE_RUBY="ruby20 ruby21 ruby22 ruby23"
# No, I am not calling ruby-ng
-inherit multilib python-r1 toolchain-funcs eutils multilib-minimal
+inherit multilib python-r1 toolchain-funcs multilib-minimal
MY_P="${P//_/-}"
SEPOL_VER="${PV}"
@@ -47,11 +47,11 @@ DEPEND="${RDEPEND}
src_prepare() {
if [[ ${PV} != 9999 ]] ; then
# If needed for live builds, place them in /etc/portage/patches
- epatch "${FILESDIR}/0005-use-ruby-include-with-rubylibver.patch"
- epatch "${FILESDIR}/0007-build-related-fixes-bug-500674-for-2.5.patch"
+ eapply "${FILESDIR}/0005-use-ruby-include-with-rubylibver.patch"
+ eapply "${FILESDIR}/0007-build-related-fixes-bug-500674-for-2.5.patch"
fi
- epatch_user
+ eapply_user
multilib_copy_sources
}