summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-10 08:00:00 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-10 08:01:38 +0200
commitb172d8dcf04580b9e1f4d8c66158cc00e14375b0 (patch)
treea7924a1e6f3344339cfa42d2cbc1d63956857894
parentapp-text/7plus: Remove last-rited pkg, #620964 (diff)
downloadgentoo-b172d8dcf04580b9e1f4d8c66158cc00e14375b0.tar.gz
gentoo-b172d8dcf04580b9e1f4d8c66158cc00e14375b0.tar.bz2
gentoo-b172d8dcf04580b9e1f4d8c66158cc00e14375b0.zip
app-editors/fb2edit: Remove last-rited pkg, #620690
-rw-r--r--app-editors/fb2edit/Manifest1
-rw-r--r--app-editors/fb2edit/fb2edit-0.0.9.ebuild33
-rw-r--r--app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch101
-rw-r--r--app-editors/fb2edit/metadata.xml15
-rw-r--r--profiles/package.mask6
5 files changed, 0 insertions, 156 deletions
diff --git a/app-editors/fb2edit/Manifest b/app-editors/fb2edit/Manifest
deleted file mode 100644
index 749d7a464686..000000000000
--- a/app-editors/fb2edit/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST fb2edit-0.0.9.tar.gz 242568 SHA256 6d64fe1597911170d6d6d59d4b36d406a9389a37c2ef5c68051176bf6f45f181 SHA512 a51eb9e7c7f70d55dc1eb06f4f7e03a031ce229570ee9620f6299cac6c2b435c8bcd702def7a50783055c066227d77b5c235f2bba231b328831b4666cc0f61b9 WHIRLPOOL 2f4ab29352318211c36fe1bfd739d69633f31ec0ce0c0a2edf4dac7965896074900f8c5b840943d900a5ff12d6cc3a819a19f7ea77201465446f17dcc9aba8cb
diff --git a/app-editors/fb2edit/fb2edit-0.0.9.ebuild b/app-editors/fb2edit/fb2edit-0.0.9.ebuild
deleted file mode 100644
index 030df92603e8..000000000000
--- a/app-editors/fb2edit/fb2edit-0.0.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="a WYSIWYG FictionBook (fb2) editor"
-HOMEPAGE="http://fb2edit.lintest.ru/"
-SRC_URI="https://github.com/lintest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-DEPEND="dev-libs/libxml2
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtwebkit:4
- dev-qt/qtxmlpatterns:4"
-RDEPEND="${DEPEND}
- x11-themes/hicolor-icon-theme"
-
-DOCS=( AUTHORS README )
-
-PATCHES=( "${FILESDIR}/${P}-fix-compiler-warnings.patch" )
-
-src_prepare() {
- # drop -g from CFLAGS
- sed -i -e '/^add_definitions(-W/s/-g//' CMakeLists.txt || die 'sed failed'
-
- cmake-utils_src_prepare
-}
diff --git a/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch b/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch
deleted file mode 100644
index 7422c505858e..000000000000
--- a/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-commit 5a378858e83e95f88ffec5e14ae1fd8157101ed0
-Author: Kandrashin Denis <mail@lintest.ru>
-Date: Fri Jul 18 23:03:05 2014 +0400
-
- Remove compiler warning
-
-diff --git a/source/fb2main.cpp b/source/fb2main.cpp
-index 50c5a80..504ccd8 100644
---- a/source/fb2main.cpp
-+++ b/source/fb2main.cpp
-@@ -27,6 +27,7 @@ FbMainWindow::FbMainWindow(const QString &filename, ViewMode mode)
- , isSwitched(false)
- , isUntitled(true)
- {
-+ Q_UNUSED(mode);
- connect(qApp, SIGNAL(logMessage(QtMsgType, QString)), SLOT(logMessage(QtMsgType, QString)));
-
- setUnifiedTitleAndToolBarOnMac(true);
-@@ -50,16 +51,22 @@ FbMainWindow::FbMainWindow(const QString &filename, ViewMode mode)
-
- void FbMainWindow::warning(int row, int col, const QString &msg)
- {
-+ Q_UNUSED(row);
-+ Q_UNUSED(col);
- logMessage(QtWarningMsg, msg.simplified());
- }
-
- void FbMainWindow::error(int row, int col, const QString &msg)
- {
-+ Q_UNUSED(row);
-+ Q_UNUSED(col);
- logMessage(QtCriticalMsg, msg.simplified());
- }
-
- void FbMainWindow::fatal(int row, int col, const QString &msg)
- {
-+ Q_UNUSED(row);
-+ Q_UNUSED(col);
- logMessage(QtFatalMsg, msg.simplified());
- }
-
-@@ -164,6 +171,7 @@ void FbMainWindow::createActions()
- FbTextEdit *text = mainDock->text();
- FbHeadEdit *head = mainDock->head();
- FbCodeEdit *code = mainDock->code();
-+ Q_UNUSED(head)
-
- menu = menuBar()->addMenu(tr("&File"));
- tool = addToolBar(tr("File"));
-diff --git a/source/fb2text.cpp b/source/fb2text.cpp
-index 0ea146f..aa2d276 100644
---- a/source/fb2text.cpp
-+++ b/source/fb2text.cpp
-@@ -37,14 +37,14 @@ FbTextAction::FbTextAction(const QIcon &icon, const QString &text, QWebPage::Web
- {
- }
-
--QAction * FbTextAction::action(QWebPage::WebAction action)
-+QAction * FbTextAction::action()
- {
- return m_parent->pageAction(m_action);
- }
-
- void FbTextAction::updateAction()
- {
-- if (QAction * act = action(m_action)) {
-+ if (QAction * act = action()) {
- if (isCheckable()) setChecked(act->isChecked());
- setEnabled(act->isEnabled());
- }
-@@ -52,7 +52,7 @@ void FbTextAction::updateAction()
-
- void FbTextAction::connectAction()
- {
-- if (QAction * act = action(m_action)) {
-+ if (QAction * act = action()) {
- connect(this, SIGNAL(triggered(bool)), act, SIGNAL(triggered(bool)));
- connect(act, SIGNAL(changed()), this, SLOT(updateAction()));
- if (isCheckable()) setChecked(act->isChecked());
-@@ -65,7 +65,7 @@ void FbTextAction::connectAction()
-
- void FbTextAction::disconnectAction()
- {
-- QAction * act = action(m_action);
-+ QAction * act = action();
- disconnect(act, 0, this, 0);
- disconnect(this, 0, act, 0);
- }
-diff --git a/source/fb2text.hpp b/source/fb2text.hpp
-index c1d1cb4..41f8a6c 100644
---- a/source/fb2text.hpp
-+++ b/source/fb2text.hpp
-@@ -169,7 +169,7 @@ private slots:
- void updateAction();
-
- private:
-- QAction * action(QWebPage::WebAction action);
-+ QAction * action();
-
- private:
- QWebPage::WebAction m_action;
diff --git a/app-editors/fb2edit/metadata.xml b/app-editors/fb2edit/metadata.xml
deleted file mode 100644
index ef67b7c2eb8e..000000000000
--- a/app-editors/fb2edit/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>pinkbyte@gentoo.org</email>
- <name>Sergey Popov</name>
- </maintainer>
- <upstream>
- <maintainer>
- <email>mail@lintest.ru</email>
- <name>Denis Kandrashin</name>
- </maintainer>
- <remote-id type="github">lintest/fb2edit</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 0c4577f958a1..d001944bcfb2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -238,12 +238,6 @@ media-sound/skype-call-recorder
net-im/skype
net-im/skypetab-ng
-# Sergey Popov <pinkbyte@gentoo.org> (08 Jun 2017)
-# Dead upstream, relies on ancient and vulnerable qtwebkit
-# See bug #620690
-# Removal in 30 days
-app-editors/fb2edit
-
# Michał Górny <mgorny@gentoo.org> (07 Jun 2017)
# The new release changes API and *breaks* core Xfce components.
# Upstream lists xfce-base/xfce4-settings and xfce-base/xfce4-panel