summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-11-13 14:48:10 +0100
committerLouis Sautier <sbraz@gentoo.org>2018-11-13 14:48:10 +0100
commitb18dc1866088a71da4cd87497070c9eb1a827858 (patch)
treec083052142d3b2aafc72d192383a13a3521bea98
parentdev-python/chump: remove old (diff)
downloadgentoo-b18dc1866088a71da4cd87497070c9eb1a827858.tar.gz
gentoo-b18dc1866088a71da4cd87497070c9eb1a827858.tar.bz2
gentoo-b18dc1866088a71da4cd87497070c9eb1a827858.zip
dev-python/flask-nav: add Python 3.7 support, fix doc deps
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r1.ebuild (renamed from dev-python/flask-nav/flask-nav-0.6.ebuild)11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/flask-nav/flask-nav-0.6.ebuild b/dev-python/flask-nav/flask-nav-0.6-r1.ebuild
index e954296d7bf4..b9a7ed2d9cea 100644
--- a/dev-python/flask-nav/flask-nav-0.6.ebuild
+++ b/dev-python/flask-nav/flask-nav-0.6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -25,7 +25,10 @@ RDEPEND="
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
@@ -45,5 +48,5 @@ python_compile_all() {
}
python_test() {
- py.test || die "Tests failed with ${EPYTHON}"
+ pytest -vv || die "Tests failed with ${EPYTHON}"
}